Warning

 

Close

Confirm Action

Are you sure you wish to do this?

Confirm Cancel
Member Login

Site Notices
Posted: 6/12/2009 3:49:35 AM EST

I have a P22 w/3.4 barrel, TI thread adapter, and SWR Spectre. I get light primer strikes with every other round. I fire a round, see it eject, the slide goes into battery loading another round. I pull the trigger and "click", nothing. I check the round and see it has indented the primer but not hard/deep enough for detonation. I tried 4 different kinds of ammo, and 6 different magazines. When I take the can off the gun works without incident. I tried a fieldstrip / relube with no joy. Suggestions?
Reply With Quote
Link Posted: 6/12/2009 6:31:50 PM EST
Does the weapon work fine without the silencer attached?
Link Posted: 6/13/2009 2:57:50 AM EST
Link Posted: 6/13/2009 6:39:29 AM EST
[Last Edit: 6/13/2009 6:39:48 AM EST by JohnStoner]
Make sure the barrel nut that holds it into the barrel sheath assembly is tight. If it's loose - the weight of the suppressor on the barrel may push the barrel back causing light primer strikes. Doesn't take much, had this problem when I used my Gemtech Trinity on my P22.
Link Posted: 6/14/2009 7:32:37 PM EST
Originally Posted By BookHound:
Originally Posted By Tennvol22:

When I take the can off the gun works without incident.






Silly me. Its the Thread adapter then.
Link Posted: 6/15/2009 8:48:31 AM EST
Tried it this weekend with a AAC Pilot and it worked like a champ. Since my Tactical Innovations mount may be to blame what are some other ones known to work with a P22 and Specre?
Link Posted: 6/15/2009 9:00:38 AM EST
[Last Edit: 6/15/2009 9:24:51 AM EST by BookHound]
Top Top