Warning

 

Close

Confirm Action

Are you sure you wish to do this?

Confirm Cancel
Member Login

Site Notices
Posted: 10/24/2010 11:32:28 AM EDT
MSAR E-4 stock
Left side of stock, looking from butt to muzzle. There is pic rail. The pic rail was removed and the screws were then screwed in the holes. The issue is two of the screws are not coming out. They are just turning. During a field strip I saw that there were small marks on the "upper" where the the ends of the screws are hitting. Has anyone had this issue? Can anyone give me any ideas on how to remove these screws? Or am I just SCREWED?
Link Posted: 10/24/2010 11:47:26 AM EDT
Pretty sure the instruction manual says not to use the screws without the rail. There is an interference where they will hit the receiver. It should also say do not over tighten because you over torque the over molded nuts. This allows them to spin freely inside the stock and you cant get the screws out. If you can get ahold of MSAR, they might replace it for you.
Link Posted: 10/24/2010 1:34:59 PM EDT
Yes it does say that in the manual. I had the E4 apart and took off the rails and just placed the screws in the holes I took them out of so I wouldn't loose them. The screws were sticking out. I took everything but stock out to clean. When I came back in to see a member of the family decided to screw them in "because they were going to fall out." Thankfully they were at the third screw out of five! This is on me and not MSAR so, I don't feel right to get them involved for "user/family" error....
Link Posted: 10/26/2010 12:38:31 PM EDT
I think you're "screwed". You'll probably need to drill them out. It sounds like the nuts molded into the stock have spun free. You can IM MSARDave, maybe he can give some suggestions.
Link Posted: 10/26/2010 1:35:55 PM EDT
Originally Posted By bco175:
I think you're "screwed". You'll probably need to drill them out. It sounds like the nuts molded into the stock have spun free. You can IM MSARDave, maybe he can give some suggestions.


MSARDave no longer exists... Jagdkommando might have some insight however. :)

This is a common problem with the E4 stocks. Requesting an RA# on the website would eventually (probably, maybe) get your stock replaced.
Link Posted: 10/27/2010 12:36:08 AM EDT
Screwed is right. I didn't contact MSAR because this is on me so, I drilled the screws out. They were on the side I wasn't using, thankfully. (reason I removed the rail to begin with) The "sleeves" or "screw inserts" came out. There is not a lot there holding them in so, make sure you don't over tighten or use any locktie. It looks a little but, she runs.
She wasn't a safe queen anyways
Link Posted: 10/28/2010 8:22:30 AM EDT
Eh’ don’t feel bad I have one stuck in my stock also and have tried to contact Micro about it but I’m still waiting on a response.......Mine is holding me up right now because I would like to sell it and scratch another itch........

Link Posted: 10/28/2010 10:58:08 AM EDT
Nice to see MSAR getting back to people in a timely fashion...
Top Top