Warning

 

Close

Confirm Action

Are you sure you wish to do this?

Confirm Cancel
Member Login

Posted: 11/15/2014 3:42:18 PM EDT
Hey all...thanks to the kindness of this forum, I am just about there! I've got four Hikvision cams (two more coming later), two older Cisco POE switches (SRW208MP), and my PC/DVR all set to go.

If I plug a Hikvision directly into the PC, it works great. But, if I plug it into one of the switches and then run the switch to the PC, I can't see it in SADP. I figured I needed to "manage" the switch, so I got me a serial cable and tried to get into it. WOW...in the owners' manual, I got to "Connecting to a switch through a Telnet session" - it says "open a command line editor and enter 'telnet 192.168.1.254'. Then press the enter key. The Login screen will now appear.

Well, I don't even know what a command line editor is; I did some googling and DLed a Linux command line editor, but that might as well have been in cyrillic. I tried using both Telnet and just a command prompt, and neither worked. I am afraid I am UTTERLY out of my league here; would any of you good folks mind giving me a nudge in the right direction?

I feel like a fool...many, many thanks, all.
Link Posted: 11/15/2014 4:11:08 PM EDT
The plot thickens.......I moved some of the jacks around, and with the PC in one slot and a camera another, it sees the camera. But not the other camera...unless I swap the two camera jacks.

SOO, I figure this must have some jacked-up settings, so I wanted to try a factory reset. THEN I discover online that the necessary cable (which originally came with the switch) isn't even a serial cable but a DB9F-DB9F straight through. So this serial cable I ordered is no good. Guess I'll find and order a straight-through 9-pin...man, this makes my head hurt.
Link Posted: 11/15/2014 4:15:38 PM EDT
[Last Edit: 11/15/2014 4:16:59 PM EDT by MrZeat]
Look up how to do a factory reset... You shouldn't have to configure anything unless you want to set up vlans to isolate the cameras which I would do.


Can you do a factory reset with any buttons, or is there a web ui you can access? I haven't looked up that switch...
Link Posted: 11/15/2014 4:33:41 PM EDT
Yeah, apparently the only way to do it is with a straight-through 9-pin cable. Irritating that straight-through a serial cables can look exactly the same yet be different...*sigh*

But it's encouraging that I can get some things to work through the switch; I hope once I'm able to do a factory reset it will cooperate.
Link Posted: 11/15/2014 6:14:59 PM EDT
I don't know about your particular switch but some of them have a specific uplink port to be connected to the p.c. Meaning that not any port will work. Once the proper port is connected to the p.c., the other ports should all behave the same. Any camera should work in any available port.
Link Posted: 11/15/2014 6:45:40 PM EDT
See, that's totally what I thought too...there are two gigabit out ports, and I really want to use one of those to go to the DVR to keep things as high-quality as possible. Oddly enough, only a camera plugged into the sixth out of eight regular POE ports will communicate with that first gigabit out; if I plug the DVR into the other, only the seventh port is recognized. So I'm *really* hoping that a factory reset should make it cooperate.

The only thing that I'll be doing that's at all strange is running two cameras into one switch, then running that switch into the other along with two more cameras; it's a weird setup for sure, but it has to do with only having access to one Cat5e from one part of the house to another. But, folks here have told me it should work fine.

It really doesn't make sense why this shouldn't be plug-and-play, and the manual is absolutely ridiculous to get into......definitely for people who actually know what they're doing!
Link Posted: 11/15/2014 8:11:02 PM EDT
My first suggestion is to remove the second switch from the picture until you can get the first sorted out.
I found your switches manual online here. https://www.cisco.com/c/dam/en/us/td/docs/switches/lan/csbms/srw208/administration/guide/srw208.pdf
according to it it is a Web Managed switch in addition to being serial cable controlled see chapter 5.

I would recommend trying the 1Gig out port to the DVR and checking the Link light color and then 1 Camera into a POE port and checking the link light color and then continue from there.

Link Posted: 11/15/2014 8:18:15 PM EDT
Couple thoughts...

Do you have a router assigning DHCP addresses to the cameras? Or have you configured them for static addresses?

You really do not need managed switches. Cisco equipment uses proprietary cables to connect to. And an entire line of certifications to learn how to configure their networking equipment.
Link Posted: 11/15/2014 9:11:27 PM EDT
[Last Edit: 11/15/2014 9:22:50 PM EDT by 50BMGdoesitforme]
Yes!! You all clearly know what you're talking about. Let me provide some needed context that I should have before.

This is for an internetless, in-home only network just for the IP cams, going to a dedicated PC DVR. By plugging each camera into the PC/DVR, I was able to assign each a separate IP.

Though the ultimate plan is for two switches, etc., right now I am experimenting with just one switch and one camera, and then two once the first one works.

When I plug any of the cameras into the one port that will work, it quickly appears in SADP under the IP address that I previously set it to. The green lights on both the PC and camera jacks on the switch blink in sync; it's pretty neat.

So...I just managed to get lucky in one of my searches, and ended up with something useful versus the usual mound of manual PDFs I get back. This site http://www.dslreports.com/forum/r21280511-Wired-SRW208-Hard-Reset-Factory-Defaults-Lost-Password seems to indicate that once I have the *correct* cable, that I should be able to get the login screen and access the switch from Hyperterminal, which is actually where the manual had me begin the process; it was not clear that I could continue using Hyperterminal as the command line editor. So, at this point, it seems hopeful that when I have the correct cable (cmon Newegg) I will be able to access the switch and reset it, since it really should be doing what I'm asking it to without any hoopla. But, these were used off Ebay, so who knows how the previous owner had them configured.

Many thanks, all!
Link Posted: 11/15/2014 11:13:13 PM EDT
Yep, use the serial then and reset it. If it's not even going to be internet connected, you can disregard the vlan stuff. All my cameras are on the same switches as the rest of my house, I use vlan tagging to isolate them.
Link Posted: 11/16/2014 7:21:37 PM EDT
[Last Edit: 11/16/2014 7:35:11 PM EDT by telc]
It's probably something configured improperly in the managed switch, I would try to factory reset it if that doesn't work. I would just get a regular POE unmanaged switch, less to configure and it will just work.

http://www.amazon.com/dp/B00E6LID0S
Link Posted: 11/17/2014 6:54:41 PM EDT
It sounds like the switch has had VLANs configured on it. Without getting into too much detail, it allows you to separate the switch into multiple virtual networks...segment the different ports into their own domain. For example, you could make ports 1,3,4 all members of the same VLAN and devices connected to those ports could communicate with eachother...but port 2 could not.

A factory reset should set it back so all the ports are in the same VLAN.

---Aaron
Link Posted: 11/25/2014 7:26:31 PM EDT
Thank you guys - worked like a charm!!

Had a few hiccups...though these switches have serial ports, they do *not* work with a serial cable, rather with a 9-pin straight through cable, which Cisco also just happens to sell. Got one way cheaper, just had to wait. Why do that? A little irritating.

Once I had a right cable, I followed the instructions on that site and it worked like a charm. Even daisy-chained the switches and it worked perfectly.

Many thanks again, all!
Link Posted: 11/25/2014 8:33:21 PM EDT
Top Top