Confirm Action

Are you sure you wish to do this?

Confirm Cancel
User Panel

Site Notices
Posted: 5/30/2002 6:40:26 AM EST
I have a old Colt SP1 that I last shot in 1980. I cleaned/lubed it with CLP and take it to the range. I put 5 rounds in the mag and shoot. The first shot fires and is ejected. The next round is chambered but when I pull the trigger, the hammer does not move. I open the gun and see that the hammer is pulled back. If I move the safety a little, the hammer goes forward a little and then the trigger can engage the hammer.

I tried the gun again. Fire one round and the gun cycles but the trigger does not engage the hammer. I wiggle the safety and now the trigger can engage the hammer. I shoot 40 rounds and the gun seems to function without needing the safety wiggle. However, once in a while (every 20 rounds or so), I need to do the safety wiggle to get the gun to fire. I looked at the lower receiver parts and the buffer tube and everything looks fine. Any ideas on what could be causing the problem?
Link Posted: 5/30/2002 6:48:16 AM EST
take it to a pro
Link Posted: 5/30/2002 7:52:34 AM EST
Did ya try looking up the problem in the -23&P? (old.ar15.com/books) or post this in the Troubleshooting section? (where Tweak - our resident AR repair expert - resides).
Link Posted: 5/30/2002 8:02:03 AM EST
I had the same problem with my Bushmaster once, and it was as rn45 said, blown out primer crap got into trigger, just cleaned it up and it worked fine afterwards.
Close Join Our Mail List to Stay Up To Date! Win a FREE Membership!

Sign up for the ARFCOM weekly newsletter and be entered to win a free ARFCOM membership. One new winner* is announced every week!

You will receive an email every Friday morning featuring the latest chatter from the hottest topics, breaking news surrounding legislation, as well as exclusive deals only available to ARFCOM email subscribers.

By signing up you agree to our User Agreement. *Must have a registered ARFCOM account to win.
Top Top