Warning

 

Close

Confirm Action

Are you sure you wish to do this?

Confirm Cancel
Member Login
Site Notices
9/22/2017 12:11:25 AM
Posted: 8/21/2005 8:06:32 PM EDT
I was out at the range yesterday and twice my gun failed to fire. The first time it happened I figured it was a bad primer, but the primer wasn't dented. I soon had it happen again and can't figure out what is causing it. I had cleaned every part of the gun, except I haven't completely disassembled the trigger mechanism, but I don't think that is the problem.
Link Posted: 8/21/2005 9:00:38 PM EDT
Are you saying it's chambering a round, but not firing it??? If everything looks OK in regards to the firing pin, then maybe either a gas leak/blockage is keeping it from going fully into battery(not driving the bolt far enough rearward to create enough momentum to fully close the bolt on the next round), or the action spring could be getting a bit weak, and causing the same problem... I'd take a good look at the gas O-ring, and make sure the gas port on the barrel is clean - after taking a good look at the firing pin...



- georgestrings
Link Posted: 8/22/2005 10:04:41 AM EDT
[Last Edit: 8/22/2005 10:06:18 AM EDT by blair50]
It was chambering the rounds, just not denting the primer. I looked at the firing pin when I was at the range and it looked fine. I was kind of thinking that it must somehow be a cycling problem. I thought this the second time it happened, but the bolt seemed to be all the way forward. It is possible that there was a gap I just didn't notice, but it all seems kinda weird to me. thanks
Top Top