Warning

 

Close

Confirm Action

Are you sure you wish to do this?

Confirm Cancel
PSA
Member Login

Site Notices
Posted: 4/30/2011 7:47:26 AM EDT
dpms stripped lower
stag 2h upper
stag lpk
stag m4 stock

Got it together last night, let me say that the springs and detents were a bit of a pain lol. anywho i got it all built and did my checks and the lower is gtg, inspect the upper/bcg/charge handle and everything looks good as far as i can tell. put er all together and went to the range this am. put a few rounds in a clip, throw one in the chamber, pull the trigger... click. nothin. so i eject that round and try another... click. check the primers and they arent even touched. seems to me that the firing pin isnt traveling far enough to hit the primer. but this is my first go around with an ar, my only other experience was shooting my buddies a few weeks ago(which is why i have my own) so has anyone had this problem? i gotta call stag monday to see if the want the bcg back or what. its under warranty. but i reeeeealllly wanna shoot so send some ideas my way!
Link Posted: 4/30/2011 8:00:04 AM EDT
If you're sure the trigger's working then take the bolt carrier group apart and reassemble it making sure the firing pin retaining pin is correctly inserted after you have the firing pin fully seated.
Link Posted: 4/30/2011 8:11:58 AM EDT
[Last Edit: 4/30/2011 8:18:49 AM EDT by CLICKBANGBANG]
Originally Posted By MMcfpd:
If you're sure the trigger's working then take the bolt carrier group apart and reassemble it making sure the firing pin retaining pin is correctly inserted after you have the firing pin fully seated.


I was thinking this too. It sounds like the retaining pin is in front of the firing pin. Reassemble the bolt carrier group. Make sure when you put the firing pin in, it goes all the way forward and stays there before the retaining pin goes in. After that pull on the firing pin. It should move back and forth freely buy not coming out and in the forward position coming through the bolt face to strike the primer.

Let us know if this fixes it.

Edit-

Even just dropping the bcg chambering a round should put a small mark in the primer. This is because the firing pin is free floating and is normal. If there are no marks at all, it is a problem in the bcg. Ether a way out of spec pin, something in the bolt carrier or out of spec, or it just assembled incorrectly.
Link Posted: 4/30/2011 8:21:15 AM EDT
just took it apart and reassembled. everything is fine as far as i can tell. there is a little pin straight across from the extractor, is this suppose to move? from the way im lookin at this thing theres no way the firing pin will ever get close to the primer
Link Posted: 4/30/2011 8:41:14 AM EDT
Originally Posted By ls1goat04:
just took it apart and reassembled. everything is fine as far as i can tell. there is a little pin straight across from the extractor, is this suppose to move? from the way im lookin at this thing theres no way the firing pin will ever get close to the primer


Yes it moves. It is the ejector. There is a spring behind it. When a round chambers, it pushes back. When the spent round is moving in reverse, the extractor holds onto the outside edge of the casing, and the ejector pushes the round out of the chamber. Flinging it out.  

Can you see the firing pin sticking out of the face of the bolt when pushed forward? Also, did you see if the rounds were fully chambered before firing at the range?
Link Posted: 4/30/2011 8:46:48 AM EDT
Remove the BCG.  
1) Push the Bolt all the way into the Carrier-  
    > Can you see the firing pin from the bolt face?
    > Is it flush with the bolt face?
2) Push the Firing Pin toward the Bolt with your finger while keeping the Bolt all the way back in the Carrier.
    > Is the Firing Pin protruding on the face of the Bolt?   [ It should be ]

If the answer is "no" to all of the above-
    > Try to remove the Firing Pin from the Bolt WITHOUT REMOVING THE FIRING PIN RETAINING PIN
If you were able to do this then the Retaining Pin was installed ahead of the Firing Pin.  Remove both then re-install the Firing Pin 1st making sure it goes all the way in.  Then install the Firing Pin Retaining Pin.  Retry steps 1 & 2.
Link Posted: 4/30/2011 8:47:53 AM EDT
Link Posted: 4/30/2011 8:55:50 AM EDT
when i push the bolt into the carrier i can see the firing pin protrude. it seems to work fine. the pin across from the extractor does not move. when i chamber a round, the bolt does not seem to go into the carrier, as if the round at the end of the bolt. i could be wrong because im new, but i know yall need facts to find the answers so im tryin.

also a few times after i pulled the trigger i would pull the charge handle to eject the round and it wouldnt come out, the extractor wasnt even grabbing the round. that made me nervous but it eventually grabbed and flung it.
Link Posted: 4/30/2011 9:08:31 AM EDT
Is the bolt cycling all the way forward?  It could be that the bolt is not fully seating the round.
( It is possible to make the hammer drop without the bolt being totally closed. )

While keeping the rifle pointed safely down range-

Chamber a round by letting the bolt slam forward.  Then use the forward assist to make sure the bolt is fully closed.
Link Posted: 4/30/2011 9:11:41 AM EDT
[Last Edit: 4/30/2011 9:15:14 AM EDT by CLICKBANGBANG]
Well thanks for hanging in there with us. We'll get this figured out after some head scratching.

Does the bolt move somewhat freely back and forth rotating in the carrier when the bolt is assembled but out of the gun? Is it snagging or gritty at all? It might be a little tight but not stuck. Like mentioned is there any burs in the cam pin cut out is what we are looking for.

Also when you were out, did you use the charging handle to let the bcg down or did you let is slam home to chamber a round? The rule is, we ride cow girls, not charging handles. The bcg needs the full momentum to properly go into battery. So pull it back and let her go.

I wonder if the chamber is a no go?
Link Posted: 4/30/2011 9:30:30 AM EDT
Originally Posted By MMcfpd:
If you're sure the trigger's working then take the bolt carrier group apart and reassemble it making sure the firing pin retaining pin is correctly inserted after you have the firing pin fully seated.


Im betting this.
Link Posted: 4/30/2011 9:56:48 AM EDT
i tried both ways, at first i was letting it go forward ridin the handle, but that didnt work. so then i locked the carrier back, inserted the clip pointed downrange and let er go. then pulled the trigger. nothing. whats the forward assist?

i know that the retaining pin and firing pin are all assembled correctly, i took it apart again just now to make sure. the pin across from the extractor has a spring behind it, so i should be able to push it in correct? because mine doesnt move. i dont want to bust anything so i didnt try hard but it seems that it might be stuck, which wouldnt let the bolt go all the way forward, which would not let the firing pin strike the primer. thats my thought process at the moment. can i get that pin out? or is this not the problem?
Link Posted: 4/30/2011 10:26:31 AM EDT
Sounds like your ejector might be binding up ... here's an exploded view.

Link Posted: 4/30/2011 10:32:39 AM EDT
[Last Edit: 4/30/2011 10:34:09 AM EDT by CLICKBANGBANG]
The ejector, spring, and retainer (parts 4, 5, and 6 in above diagram) are difficult to take apart and get back together. You need a very small punch to do it. Also loosing the parts while dissasembling and reassembling, is almost a sure thing. So without spare parts on hand, I might not pull it apart.

But it should move. You can't press it in buy hand. You'll have to get a screwdriver or punch, flip the bolt up, and put it on ass end. Then with the bolt on a counter or something sturdy, use the punch and press the ejector down all the way flush with the bolt face. It should be stiff but springy and return all the way back up.
Link Posted: 4/30/2011 10:36:18 AM EDT
It doesn't eject the chambered round?
Link Posted: 4/30/2011 10:37:31 AM EDT
ok ejector moves using your advice. now im lost.
Link Posted: 4/30/2011 10:39:18 AM EDT
There is a chamber obstruction?
Link Posted: 4/30/2011 10:42:33 AM EDT
chambers clear. i can see that carrier isnt all the way forward with a round in, compared to an empty chamber. is it suppose to be this way?
Link Posted: 4/30/2011 10:42:35 AM EDT
[Last Edit: 4/30/2011 10:43:08 AM EDT by Gatorhunt]
Could be an out of spec bolt not allowing the firing pin to protrude far enough past the bolt face to ignite the primer .... or out of spec (short) firing pin.


ETA sounds like you have a headspace issue
Link Posted: 4/30/2011 10:43:09 AM EDT
[Last Edit: 4/30/2011 10:51:57 AM EDT by TurboniumOxide]
It sounds like something in the chamber since the extractor gets enough lip to grab, and the ejector ejects the round, yet it won't go into battery enough to lock and let the bolt rotate enough to let the firing pin hit the primer.

Link Posted: 4/30/2011 10:44:48 AM EDT
[Last Edit: 4/30/2011 10:46:25 AM EDT by TurboniumOxide]
It sounds like an out of spec chamber.

ETA or headspacing very wrong.
Link Posted: 4/30/2011 11:25:36 AM EDT
OP you are using factory ammo and not reloads correct? I've seen reloads that weren't properly re-sized do stuff like this because they can't chamber correctly and usually get stuck as chuck.

I would try another bolt if you have one or can get your hands on one ... if that doesn't work then like Turbo said the chamber might be out of spec (little short) ... you need to have someone check the headspace for you.
Link Posted: 4/30/2011 12:09:50 PM EDT
Originally Posted By ls1goat04:
chambers clear. i can see that carrier isnt all the way forward with a round in, compared to an empty chamber. is it suppose to be this way?


No. The carrier needs to as far forward with a live round as it is with an empty chamber. If the bcg is not all the way forward, the the bolt is not locked up properly. In the even the round does go off when the bolt is out, bad things happen.

Earlier we mentioned using the forward assist to see if the bolt was all the way in battery with a round. If the assist does not close the bolt into the locking lugs all the way with minor effort, then I'd say we have an out of spec chamber or no go head spacing. ––I would really like to see a pic of the bcg through the ejection port with and without a round chambered–– However, you must do this safely. I don't want you to shoot something not ment to be shot.––

At that point, I would for sure contact the manufacture of the upper. Let them know the upper is not chambering ammo, and is out of spec in some way. Send it in and have them fix or replace it. It does happen that parts do get sent out after quality control missed the out of spec upper. Most manufactures do test fire upper so this is a little rare.
Link Posted: 4/30/2011 1:22:40 PM EDT
[Last Edit: 4/30/2011 1:25:36 PM EDT by ls1goat04]
ok this is where im at. i took sharpie and marked on the hammer. put the gun together and dry fired. the hammer is indeed hitting the firing pin. so the mechanics are correct. i have pictures of the pin sticking threw the bolt, and of one in the chamber

http://i53.tinypic.com/mlmsdw.jpg
http://i55.tinypic.com/a9vdz.jpg
Link Posted: 4/30/2011 1:28:38 PM EDT
Originally Posted By ls1goat04:
chambers clear. I can see that carrier isnt all the way forward with a round in, compared to an empty chamber. is it suppose to be this way?


No.........The bolt should close all the way whether there is a round in the chamber or not.  The Forward Assist is that plunger mechanism behind the ejection port on the right side of the upper.  It has a paw on the inside that pushes against the serrations on the bolt to "assist" in closing the the bolt completely.  ( Some people routinely use it, others never touch it.  But that's' a discussion for another time. )

 It may be, as others have said, that the head spacing is wrong or the chamber is out of spec.  But that is rare and not something you can fix without returning the upper to the manufacturer since this would obviously be a warranty issue.  If your chamber appears clear ( no dirt or foreign material ) then I would next look at the ammo before taking that drastic step.

How many different rounds have you tried to chamber?  By that I mean, are you putting the same exact round back in the rifle every time?
If so that single round could be the issue.  
Have you tried other brands of ammo?  What are you feeding your rifle right now?

Link Posted: 4/30/2011 1:32:40 PM EDT
ultramax 55g bulk ammo from dicks, i fed 20 different rounds threw it, not one had indentations on the primer. at this point its goin back to stag. i bought stag because ive read its not the best, but not the worst. right now im a smidge irritated. hopefully they can make it right in a timely fashion.
Link Posted: 4/30/2011 1:37:17 PM EDT
Unload the weapon and bring it to a Gunsmith. Could be mechanical.
Link Posted: 4/30/2011 2:16:03 PM EDT
Don't ride the charging handle forward.  Sounds like your bolt isn't going fully into battery because you're riding it forward.  Pull the charging handle fully rearward, then release it.  Should work fine.
Link Posted: 4/30/2011 2:29:13 PM EDT
I took a close look at the bolt closed on a round pic. It might have looked a little off. Pulled it up on my iPhone and sized it to 1.1 scale and held it up to my three uppers I have laying here right now. Colt, RRA, and DPMS. All of them show the bolt carrier sitting farther forward. I think it's the upper. Not something you did in assembly or a mistake at the range.

I would call Stag first thing Mon morning. Have your order number handy. They might ask all the same questions we did and then tell you to send it in. I'm sure they will fix it. Stag has a good reputation for making good guns. Hopefully they turn it around fast. I would ask to get the persons email and send them the link to this thread. Might light the encouraging fire of making a good customer serves showing.
Link Posted: 4/30/2011 3:01:04 PM EDT
i stripped the gun again, inspected and cleaned everything. put it together, and decided id go try it one last time. i get to the range, pull the charge handle back and let go. she looks seated. i push the forward assist to make sure... point down range.... pull the trigger... BOOM! Hot damn we got a winner! now if i could learn to shoot the damn thing id be in business haha. i appreciate all the help from you guys. im a member on alot of forums and have never got this type of help! anywho after some movin around i got this at 50 yards.
http://i55.tinypic.com/16gcz04.jpg
Link Posted: 4/30/2011 4:29:29 PM EDT
It's alive!!!

What did you do different? Did you find anything when you cleaned it out? Maybe a harder launch on the action did it?

Anyway just glad you have a shooter! It is a bummer to have a gun not running. After your first the rest are much easier to do. How many rounds did you get a chance to shoot? Now you have to finance feeding the thing.
Link Posted: 4/30/2011 4:42:00 PM EDT
I was about to ask if you were stuffing 5.56mm ammo in a 223 barrel!?!?!?  Super you got it fixed, and that's not bad shooting man.  You are probably so pumped with adrenaline that you could hold still anyway.

What was the issue?  Were you riding the charging handle?  It's a gun, so pull back and let go!  If that was all, that was an easy fix...Operator error.  I was thinking broken firing pin, but I do not know how you could break one...they are pretty stout.  Other than that...I was starting to scratch my head from what you had tried and what was recommended.  Let us know what the real issue was...

Rob
Link Posted: 4/30/2011 5:13:06 PM EDT
Originally Posted By CLICKBANGBANG:

What did you do different?


He said he pushed the forward assist.  IOW, he was riding the charging handle forward.
Link Posted: 4/30/2011 5:18:51 PM EDT
yup i was riding the charge handle. noobie mistake. sorry for all this confusion over my rookie problems. but i know i had it seated good earlier and it wouldnt fire. i think me going threw and cleaning the crap off from the factory helped. im guessing it wouldnt take much to make it malfunction. thanks again guys! now if yall got some shooting tips hook it up! i shoot alot of trap and bolt guns, but the bolts and my slug gun are scoped so its easy haha
Link Posted: 4/30/2011 5:36:29 PM EDT
Well, after taking it apart and putting it back together so many times, you are now probably a pro at it.

I'm glad you got it running. New rifles can be a little tight. After a couple of thousand rounds it will be smooth as butter.

Link Posted: 4/30/2011 6:23:16 PM EDT
We ride cowgirls, not charging handles.
Link Posted: 4/30/2011 6:38:05 PM EDT
Glad to see your up and running  

Welcome to the site.
Top Top