Warning

 

Close

Confirm Action

Are you sure you wish to do this?

Confirm Cancel
Member Login
Posted: 8/17/2004 7:58:36 PM EST
I went out shooting today, had an eotech 551 on the M4 and bushnell holosight on the FAL. it was a bit bright, even though i was shooting at around 6pm. i noticed the eotech was washing out bigtime, to where i could BARELY see the dot at 50 yards on the paper, while the bushnell was bright and clear as day.

It looks nice and bright against a dark background, the same as the bushnell, but out on the range i cant see anything and i have to aim it at something dark and "walk" it over. the bushnell looks nice and crisp over the paper.

i put in a brand new set of batteries right then and there with no change.

something is obviously wrong. anybody have any suggestions? does eotech repair sights for 2nd owners?
Link Posted: 8/17/2004 10:02:03 PM EST
Link Posted: 8/18/2004 4:24:13 AM EST
Something is wrong with your EOthingy. I live in AZ where we have enough sunlight to jump start a nuclear reactor. I've yet to have a need to go to the highest brightness setting.

SD
Link Posted: 8/18/2004 11:00:52 AM EST
Second that, I shoot out in Northern CA and now it's as bright as the desert out and 100+ every day. I still have to click my thingy down 1 or 2.
Link Posted: 8/18/2004 4:25:23 PM EST
I've had the Eotech sort of washout in really bright conditions twice in Texas(Not bright enough to easily distinguish the center 1 MOA dot from the background). Once during a tactical classe and once in a day tiem shooting.



The Sights been to Eotech and return with no problems found.

It is a model 512.
Link Posted: 8/19/2004 6:58:10 AM EST
ok, now its completey screwed. it just started changing levels on its own then shutting off.

man i hate mail in repairs!
Link Posted: 8/19/2004 2:33:22 PM EST
THey will take care of repairs very quickly.

Eotech has very good service, all you have to do is call and get an RMA # and then send it in.
Top Top