Warning

 

Close

Confirm Action

Are you sure you wish to do this?

Confirm Cancel
Member Login

Site Notices
4/22/2019 5:32:20 PM
Posted: 1/21/2013 2:08:12 PM EDT
I used greentips to zero this sight at 50yards about three weeks ago. I had to rezero it today. Greentips again at 50 yards. My zero was off to the left about 1.5 inches and down an inch. I shot a 2.5 inch group today at 50 yards, and 4.5 inches at 100 yards. At 100 yards the group was still centered horizontally, so that seemed good. Anyways, do these EOtechs often need rezeroing? I did not take the sight on and off the rifle or anything. Brand new sight and rifle. No low battery indications. Help me out here. Thanks.
Link Posted: 1/21/2013 2:31:24 PM EDT
Never had a problem with eotech holding a zero. 6years using them. currently exps2-0 and exps3-0. I'd say try again making sure fundamental shooting techniques are emphasized. Just curious, how's it mounted??
Link Posted: 1/21/2013 3:16:56 PM EDT
Could have been ammo variances. Unless you messed with the position on the EO it should not need to be zeroed again.
Or you had bad fundamentals before. Was it holding zero once you set it the 2nd time?
Link Posted: 1/21/2013 3:25:24 PM EDT
m855 is about 2 to 4 moa , try some m193 and see if your groups tighten up. m193 is usually 1 to 2 moa .
Link Posted: 1/21/2013 4:33:15 PM EDT
I was shooting both days from a sand bag rest. It seemed very steady. I used a five shot zero the first time. Maybe it was not zeroed the first time. This time I grouped eight shot groups for my zero this time.
Top Top