Warning

 

Close

Confirm Action

Are you sure you wish to do this?

Confirm Cancel
BCM
Member Login

Site Notices
Posted: 2/24/2010 8:27:18 AM EDT
I am starting to see a white looking haze on areas the lower reciver of my Daniel Defense M4. I wipe it down using Slip EWL but even a day later this white haze reappears. Any suggestions as to what this is and why it appears? Thanks in advance.

UPDATE: Apprently I am using the search tool here wrong as no matter what I search for it replies "no match results found". I have just read of someone else having the same problem with the white or ghosting which they were told use CLP, I wil try that and see if it remedies my issue. Thanks. Any idea why my search never finds results?
Link Posted: 2/24/2010 9:07:12 AM EDT
Quoted:
I am starting to see a white looking haze on areas the lower reciver of my Daniel Defense M4. I wipe it down using Slip EWL but even a day later this white haze reappears. Any suggestions as to what this is and why it appears? Thanks in advance.

UPDATE: Apprently I am using the search tool here wrong as no matter what I search for it replies "no match results found". I have just read of someone else having the same problem with the white or ghosting which they were told use CLP, I wil try that and see if it remedies my issue. Thanks. Any idea why my search never finds results?


I could be wrong but seeing as how its Aluminum, there's a good chance the Aluminum is oxidizing.
Link Posted: 2/24/2010 9:19:25 AM EDT
Quoted:
Any idea why my search never finds results?


Spray paint.
Link Posted: 2/24/2010 9:21:59 AM EDT
Quoted:

UPDATE: Apprently I am using the search tool here wrong as no matter what I search for it replies "no match results found". I have just read of someone else having the same problem with the white or ghosting which they were told use CLP, I wil try that and see if it remedies my issue. Thanks. Any idea why my search never finds results?


The search here only searches the thread titles not the body of the thread.
Link Posted: 2/24/2010 10:28:32 AM EDT
I'm pretty sure it's Teflon, or some other additive in the oil.   Don't know what the best method is, for cleaning off the teflon.  Hopefully, somebody will chime in about it.

FWIW- I rubbed down an AR with Mobil One the other day.  It seemed to leave a nice black surface.
Link Posted: 3/9/2010 7:59:45 PM EDT
LSA.....
Link Posted: 3/10/2010 5:54:04 AM EDT
I remember that thread, but can't find it.  If I recall correctly, the guy tried CLP with little luck, even after leaving it on overnight and then wiping it down.  I think it was Remoil that did the trick for him.

ETA:  found it:  http://www.ar15.com/forums/topic.html?b=3&f=118&t=485672
Link Posted: 3/10/2010 6:04:06 AM EDT
Quoted:
Quoted:

UPDATE: Apprently I am using the search tool here wrong as no matter what I search for it replies "no match results found". I have just read of someone else having the same problem with the white or ghosting which they were told use CLP, I wil try that and see if it remedies my issue. Thanks. Any idea why my search never finds results?


The search here only searches the thread titles not the body of the thread.


Even still, the search function doesn't work, because I searched for the word "accept" and "finish" separately and the thread I provided above didn't come up.  I had to go like 15 pages back and find it myself.
Top Top