Warning

 

Close

Confirm Action

Are you sure you wish to do this?

Confirm Cancel
Member Login

Site Notices
1/22/2020 12:12:56 PM
Posted: 9/20/2009 2:40:04 AM EST
HI GUYS
yesterday i clenaed my bushmaster and today i used ..
but i had a probloem...
with every mag, plastic magpul and metallic usgi, the rifle close the bolt at empty mag.
every time i shoot the last round as a "click" , with no ammo in the chamber and bolt closed...

any idea on how to fix it?
the rifle have 5 months, the magpul mags have 2 weeks
ciao
andy in italy
Link Posted: 9/20/2009 5:05:34 AM EST
[Last Edit: 9/20/2009 5:06:10 AM EST by andy_ita]
guys the rifle have 6 months
i fired 2500 rounds circa

now i tryed an old colt a2 and the mags work
then i :
changed bolts no stop
swapped the upper receiver from my 16" with the 20 " using the same lower .no stop
using another mag, i had this problem aftert the last round




the bolt dont stai opened touching the bolt face, but the middle of the bolt carrier , then when i inser the second mag and close the bolt using the mag catch, i have empty chamber


when i fire, it seem the bolt cicle 1 time and a half
when i fire i hear the recoil , like the bolt close then move rear again for a bit then close again

5 months ago i changed the buffer with the anidine recoil buffer...could it create problems?
Link Posted: 9/20/2009 5:14:36 AM EST
[Last Edit: 9/20/2009 5:25:31 AM EST by Dystopia]
While you were cleaning it did you accidently dry fire it with the rifle opened and dented the lower in a little?

OR

It may be short stroking and it’s catching the bolt in the wrong spot sometimes or not at all.
Link Posted: 9/20/2009 5:41:55 AM EST
When you pull the charging handle does the bolt go back a lot farther then that?
Link Posted: 9/20/2009 7:31:25 AM EST
well it is possible that i pull the trgger when the rifle was open...but it should not create a problem cause the hammer does not touch the bolt catch.
and about your other question...well i dont know...

i tryed the other 20" upper receiver with same results.
this upper is new, and have his hown bolt. i fired only 20 rounds , but i got same problems..
so the prblem is in the lower , not in the upper...but i dont know where....
Link Posted: 9/20/2009 4:27:18 PM EST
Originally Posted By andy_ita:


5 months ago i changed the buffer with the anidine recoil buffer...could it create problems?


As a couple others said on M4C.Yes that buffer could cause issues,especially with the ammo you are using.Put the lower back to its original configuration and try again.
Top Top