Warning

 

Close

Confirm Action

Are you sure you wish to do this?

Confirm Cancel
Member Login

Site Notices
Posted: 11/1/2006 7:24:09 PM EST
I just tried to install my DD Burnsed loop onto my rifle with a Vltor buffer tube and the tube is not threaded enough. I do not have enough room to turn the tube on far enough to retain the buffer stop, even with the castle nut backed off as far as it will go. The protrusion on the loop that sticks into that relief on the receiver does not clear.

Has anyone else had this problem? I am using a castle nut from an el cheapo non-milspec stock, could that be it? Does Vltor thread their tubes to only fit their mounts or something?

Thanks for the help!
Link Posted: 11/2/2006 3:22:32 AM EST
I have a DD Burnsed sling mount installed with a Vltor receiver extention and everything fits just fine. I have also tried this same DD sling mount on my other Vltor receiver extension it worked just fine as well.

Assuming you have it all together correctly, it's very possible that you got a bad receiver extension. You may want to contact the dealer you got it from and see about getting a replacement.
Link Posted: 11/2/2006 3:39:43 AM EST

Originally Posted By Hooligan22:
I just tried to install my DD Burnsed loop onto my rifle with a Vltor buffer tube and the tube is not threaded enough. I do not have enough room to turn the tube on far enough to retain the buffer stop, even with the castle nut backed off as far as it will go. The protrusion on the loop that sticks into that relief on the receiver does not clear.

Has anyone else had this problem? I am using a castle nut from an el cheapo non-milspec stock, could that be it? Does Vltor thread their tubes to only fit their mounts or something?

Thanks for the help!

Ah hah!
You left that out on your other post.
It could be, but I would still think that it is more than likely the extension isn't threaded fully from what you've said.
As far as VLTOR being propietary threading, I've used a standard plate, a DD plate, and two plates from Gear Sector on my VLTOR extensions. The only issue I had was a plate that was too thick to allow my VLTOR to fully collapse.
Link Posted: 11/2/2006 4:27:49 AM EST
I didn't think it was a big deal because I looked at a bunch of pictures of castle nuts last night and I was not able to tell a difference between them, and I didn't find different castle nuts that were milspec and non-milspec.

I have been in contact with Steve@ADCO and we're working on it. I am going to snag some pictures when I get home from work tonight.

My guesses are that the tube isn't threaded far enough or that my receiver is out of spec. I thought Mega was supposed to be a pretty good brand of receiver, so I threw that out as a possibility initially.

Thanks for the help.
Link Posted: 11/2/2006 5:23:56 AM EST
I have also been in contact with someone at Vltor and it sounds like they had a very small batch of tubes go out that were missing about 1/4" of thread. They are replacing my tube free of charge, even shipping. Great customer service from both Vltor and Steve@ADCO! Thanks guys!
Top Top