Warning

 

Close

Confirm Action

Are you sure you wish to do this?

Confirm Cancel
PSA
Member Login

Site Notices
Posted: 4/29/2009 8:57:53 AM EDT
[Last Edit: 4/29/2009 9:13:46 AM EDT by pushc6]
So, got my aimpoint in a few days ago.  Went to put the battery in and fire it up and it didn't turn on.  After some fuddling and trying another new battery no dice.  So that's when I see the foam down where the battery sits in the battery compartment like in the picture below.  I tried just putting more force on the battery with the cap off and it turned on.  So I tried moving the foam to the top and it seems to work.  My question is it looks like the foam belonged down at the bottom because of the hole for the spring, is there another piece of foam in the top of the cap that may have fallen out when I opened it up for the first time?  Inside the cap was just bare metal before I moved the foam insert.  The picture below looks like it has a rubber insert or something in the cap, mine is bare metal.   Thanks in advance!

http://img409.imageshack.us/img409/7382/p1010336eo2.jpg
Link Posted: 4/29/2009 1:46:25 PM EDT
Ok, if I just set the battery in the compartment and give it the lightest amount of pressure it works, but as soon as I put the cap on the light goes out.  It's like the cap is either shorting it or not letting it make the proper contact.  But if I put something up in the top of the cap it looks like it may work.  So is there supposed to be something in that upper cap like there is in that M2 picture?
Link Posted: 5/1/2009 3:53:30 AM EDT
Found my problem.  Spoke with John @ Aimpoint and he informed me that there was supposed to be a rubber insulator in the battery cap.  I guess a few units went out without one in there and it will lead to problems with the sight turning on.  So if you are one of those who are missing the insulator just give them a call and they will make things right.  Should get my new cap in the next couple days.
Link Posted: 5/1/2009 7:12:59 PM EDT
Good deal. Aimpoint, is good folks.
Top Top