Warning

 

Close

Confirm Action

Are you sure you wish to do this?

Confirm Cancel
Member Login

Site Notices
Posted: 11/3/2009 5:31:45 AM EST
I bought a new Lauer Custom Weapons lower. I put on my new Larue Stealth Upper and dry fired it several times. I noticed that when I pulled the trigger after manually cycling the bcg. the trigger drops the hammer normally. However, if I hold the trigger back after firing and then pull and release the BCG, the hammer goes back, but the trigger wont reset when I let the pressure off. I have to push it forward to get it to reset. Also, if the BCG is held back by the bolt stop, the trigger hangs loose. It just flops forward and back as if it isn't attached to anything.

Could I be missing a spring or something?
Link Posted: 11/3/2009 9:08:56 AM EST
Originally Posted By CarbonBuildup:
I bought a new Lauer Custom Weapons lower. I put on my new Larue Stealth Upper and dry fired it several times. I noticed that when I pulled the trigger after manually cycling the bcg. the trigger drops the hammer normally. However, if I hold the trigger back after firing and then pull and release the BCG, the hammer goes back, but the trigger wont reset when I let the pressure off. I have to push it forward to get it to reset. Also, if the BCG is held back by the bolt stop, the trigger hangs loose. It just flops forward and back as if it isn't attached to anything.

Could I be missing a spring or something?


Go to the how to's in the build it yourself area of this forum . Compare the pictures to what you have .

God bless
Wyr
Link Posted: 11/3/2009 1:17:54 PM EST
Wyr, Thanks for the advice. I took out the parts and the trigger spring was backwards or upside down or some goofy sh&*. I put all back together correctly and now its working fine.
Link Posted: 11/5/2009 12:18:05 PM EST
[Last Edit: 11/5/2009 12:19:00 PM EST by WyrTwister]
Originally Posted By CarbonBuildup:
Wyr, Thanks for the advice. I took out the parts and the trigger spring was backwards or upside down or some goofy sh&*. I put all back together correctly and now its working fine.


Glad to hear you have the problem solved . :-)

I installed another Lower Parts Kit earlier in the week . In a DPMS lower .

I went back to the how-to's to try to figure out the way the springs go . I seem to have gotten it correct .

God bless
Wyr
Top Top