Warning

 

Close

Confirm Action

Are you sure you wish to do this?

Confirm Cancel
Member Login

Posted: 10/28/2013 5:44:49 AM EST
I just put the trigger group in my completed 80% lower.

When doing the functions check, the trigger will not reset.

Charge
Pull trigger - hammer drops - maintain pressure on trigger
Charge
Release trigger - hammer drops again.

any ideas?
Link Posted: 10/28/2013 5:52:11 AM EST
[Last Edit: 10/28/2013 5:53:12 AM EST by MisterPX]
Disconnect installed correctly, correct shape?


ETA: by correct shape, I mean not worn down, bits broken off.
Link Posted: 10/28/2013 5:54:32 AM EST
Originally Posted By fluwoebers:
I just put the trigger group in my completed 80% lower.

When doing the functions check, the trigger will not reset.

Charge
Pull trigger - hammer drops - maintain pressure on trigger
Charge
Release trigger - hammer drops again.

any ideas?
View Quote


Could the holes be out of spec?
Link Posted: 10/28/2013 5:58:41 AM EST
Disconnector spring installed correctly?
Link Posted: 10/28/2013 6:29:25 AM EST
Trigger spring installed upside down.
Link Posted: 10/28/2013 1:25:05 PM EST
Out of spec receiver? This has proven to be pretty helpful:

SELECTOR TEST

For this test, you will only need the lower receiver group. Prior to performing the test, ensure that all parts and springs are properly installed.

1. De-cock the weapon and place the selector in the FIRE position.
2. Pull the trigger and hold it tightly to the rear until the next two steps are completed.
3. Force the hammer back onto the disconnector.
4. Rotate the selector to the SAFE position.

PASS: Hammer resets on the trigger.

FAIL: Hammer falls to the fired position.

If your weapon fails the selector test, replace the following parts (with known good ones) in order and repeat the test after each part is changed.

1. Disconnector Spring
2. Disconnector
3. Hammer
4. Trigger

If the weapon fails after all parts have been replaced the receiver is unserviceable.
Link Posted: 10/28/2013 3:11:52 PM EST
Originally Posted By fluwoebers:
I just put the trigger group in my completed 80% lower.

When doing the functions check, the trigger will not reset.

Charge
Pull trigger - hammer drops - maintain pressure on trigger
Charge
Release trigger - hammer drops again.

any ideas?

Simple guess is that you have one of the springs upside down, take a look at a known correctly installed sample or a diagram of correct installation.
View Quote

Link Posted: 10/28/2013 4:51:18 PM EST
Thanks for the ideas.

I double checked all the springs and everything was put in correctly.

I just replaced the entire fire control group and it works fine now. I'm not sure what part(s) were causing the problem.
I'll probably just send the whole set back for exchange.

I'm very relieved that there was nothing out of spec with the receiver.
Top Top