Warning

 

Close

Confirm Action

Are you sure you wish to do this?

Confirm Cancel
Member Login

Site Notices
Posted: 3/14/2009 9:26:55 AM EDT
I bought a saber defence a couple of months ago. It didnt cycle properly when I first got it but thought it wasnt broke in. I have finally had some time to mess with it and it is still not cycling properly. What it seems to me when I shoot it is the bolt is only going half way back, and does not eject the casing. I can cycle the next round in by using the charging handle. The bolt doesnt hang or anything.

I was told before it wasnt broke in, and that I was using reloads that were not hot enough. OK good enough! I have shoot factory loads over 200 with no better results. I have used Hornandy, wolf, and fiochhi with no better results. I did load up some real hot loads that would eject the brass, but wouldnt pick up the next shell properly. It would grab the next round in the middle of the shell. I dont have a clue what is going on.

It is 20" hbl with a RRA BCG. I have check the gas tube, gas block and gas key and they are all clear. The gas key is properly staked. I have used old, new diffrent types of magazines. I have ran it wet, and dry. The lower is a DPMS with a RRA 2 stage trigger. It has A2 stock with buffer. What else do you need to know?

So what do you think? Is there something wrong with the buffer spring? This is driving me nuts. Thanks in advance!

Link Posted: 3/15/2009 12:20:02 AM EDT
Short stroking. Provided you haven't installed anything else that would prohibit the bolt from cycling, there's not enough gas to operate bolt. There are pinned topics that cover this
Link Posted: 3/15/2009 11:29:00 AM EDT
Link Posted: 3/28/2009 3:48:40 PM EDT
I have exactly the same problem.

Saber 20" 1 in 7 " twist ,Cerro forge upper, F marked FSB. Bought it in December from a vendor above. I installed a Larue Bolt Carrier Assy, and a PRI gasbuster charge handle.

I have tried many magazines all with the same effect ( although 1 Pmag only had 1 fail to feed in 20 rds).
I have swapped out 3 different lowers. I have now shot about 90 rounds thru it and it's getting a little better.
The barrel will not hold a very good group but it's getting a little better. Using PPU 75gr rounds I had a 5" group using an ACOG 4x.
I switched to PPU 62gr and now I'm getting about a 3" group with th 4x ACOG @ 100 yds.

I have tried three different brands of ammo and bullets and all have the same cycle problem.

I'm shooting it pretty wet. The chamber looks fairly smooth. It feels like I'm getting a good gas impulse. When the mag empties, I can feel the half cycle and the bolt locks back. The carrier feels good in the upper.


Mine makes a good trainer, built-in ball and dummy drill rifle.

I'm going to give it another 100 rds and if it doesn't clear up call Saber.

Are your mags sticking in the gun ? Mine might be an out-of-spec upper now that I feel it.

J
Link Posted: 3/28/2009 9:17:31 PM EDT
[Last Edit: 3/28/2009 9:20:26 PM EDT by fixit]
What do your case heads (rims) look like? Can you post a few pictures of them?
Top Top