Confirm Action

Are you sure you wish to do this?

Confirm Cancel
Member Login
Site Notices
1/25/2018 7:38:29 AM
Posted: 2/22/2006 8:33:03 PM EST
It's a Eagle lower with DPMS LPK and an ArmaLite upper assy.

Anyway. I chambered a Winchester (55gr FMJ) round, took aim and CLICK. Nothing. Ejected and chambered another. Same thing. Tried five or six more times with the same result. Upon inspection, I noted the primers had a small dimple. Upon further inspection, I noted the dimple was not due to chambering. I pulled the carrier and could move the f/p moving freely. Closed it all up and tried again. Same result. After considering going to the house, I tried some Remmy ammo which I had in another mag. Perfect function for all 20 Remmy rounds. Then I once again tried (previously unchambered) Winny ammo. Perfect function. I fired the rest of the win. In total I fired 20 Rem then 40 Win. with no problems after the initial smeg-up. I'm scratching my head. Does anyone know what in the smeg happened?????
Link Posted: 2/22/2006 10:44:26 PM EST
[Last Edit: 2/22/2006 10:48:43 PM EST by HarrySacz]
Thats weird, i think your firing pin may have been stuck,maybe it came loose when you took the bolt out? Someone with more knowledge will be along shortly.
Link Posted: 2/26/2006 9:19:43 AM EST
I had it out again yesterday and it ran great. Not one failure. Mabye it was a "breaking in" issue, although I've never heard of that one.
Top Top