Warning

 

Close

Confirm Action

Are you sure you wish to do this?

Confirm Cancel
Member Login
Posted: 10/15/2004 11:32:51 AM EST
mine is NO-GO.

i tried this trigger in 2 different lowers and each time im about 0.080 shy of making it. the thickness of the collar (where the pin goes thru on the bottom) still shows in the pin hole. is this a NORMAL occurrence or do i have an abnormal trigger?

theres not a huge rush to get this together but im kind of in the groove with it now and would like to finish it...

can anyone point me in the right direction? putting both RRA and Bushmaster triggers side by side on a measuring plate doesnt show any differences that i can see. the RRA i put in my Colt went without a hitch. in fact EASIER than i expected...

HELP!

david
Link Posted: 10/15/2004 11:52:18 AM EST
When you remove the hammer/trigger springs and just "eyeball" the assembly in place, does it line up properly?
Link Posted: 10/15/2004 12:37:07 PM EST
it should be drop in fit
Link Posted: 10/15/2004 2:18:10 PM EST
yes it does. i thought that the spring coils may be the culprit but didnt know how to handle that...

david
Link Posted: 10/15/2004 3:01:31 PM EST
please clarify for me what parts are not fitting correctly
Link Posted: 10/15/2004 3:48:11 PM EST
when i try to put the trigger in it does NOT fit deep enough (roughly the thickness of the shoulder on the pin hole) into the receiver. you can see that it does not go into the lower far enough to get the pin into it...

david
Link Posted: 10/15/2004 7:56:56 PM EST
Maybe the parts are out of spec. Mine went in much easier than I expected, and I'm quite pleased with it. Maybe you should send it back for an exchange.
Link Posted: 10/16/2004 3:40:16 AM EST
no, i was an idiot...

the part of the spring that crosses in front of the trigger and connects the 2 coils on either side, wsa slipping down and causing interference...

i didnt figure it out until

A) i had another Coke

B) watched the hottie weather lady on the local 11pm news

C) put the spring back on (following a suggestion to try it without the spring)


thanks for youre help. it was a stupid mistake but it helped to set up another troubleshooting step...

david
Top Top