Warning

 

Close

Confirm Action

Are you sure you wish to do this?

Confirm Cancel
Member Login

Site Notices
12/6/2019 7:27:02 PM
Posted: 1/21/2008 8:42:50 AM EST
Need some help. I have a new RRA lower that I took to the range to function test. I was using a Bushmaster Upper and would chamber a round fire that round and then nothing. No click no bang nothing. It was cycling as there was another loaded round in the chamber. Trigger control group Problem? Ammo was Black Hills and Mags NHMTG. Thanks guys.
Link Posted: 1/21/2008 9:27:13 AM EST
I had trouble last week with a new RRA lower, Mostly my trouble was with getting 20rd mags to fit, but I did have a few FTF. I just sent in the lower to RRA due this problem. Look into your magwell while the upper is attached to see if there is a lip from the upper protruding. Look at my thread pics to see if you have the same fit issue.

www.ar15.com/forums/topic.html?b=3&f=66&t=358529
Link Posted: 1/21/2008 11:48:33 AM EST
I had the same problem seating magazines except for 30rd CProducts. After checking the mag well as suggested, I do have a protrusion. My question now is this. This was a stripped lower I bought new to put together as a patrol rifle. Will RRA still fix this? I have owned and built several Colt, DPMS, and Bushmaster rifles and never had an issue. Kinda of dissapointed with the RRA. I was just about ready to order my upper from them, but now I'm not sure. Any suggestions?
Link Posted: 1/21/2008 12:14:11 PM EST
I built mine up as well. I took most of it apart to ship back to them. It is scheduled to arrive to RRA on WED or Thursday. I will post what happens in my original thread. This brings the count up to 3 here that have this problem.
Top Top