Warning

 

Close

Confirm Action

Are you sure you wish to do this?

Confirm Cancel
Member Login
Site Notices
Posted: 9/4/2004 6:42:13 PM EST
[Last Edit: 9/4/2004 6:43:33 PM EST by WillMunny]
Shot my new SPR today for the first time and ran into a couple problems that I'd really like some help with. First the rifle's specs: UPPER: MSTN-built clone SPR Mark 12 Model 0 upper (LMT upper, LBC bolt & carrier, PRI Fat Boy Charging Handle) bought slightly used on the EE. LOWER: Colt postban MT6400C.

1. I had a bitch of a time pulling back the charging handle! From the start I had to pull with excessive force to pull the handle back. After taking the upper apart and looking at it closely, it seemed to me as if the very back part of the PRI handle, where it slides just under the back end of the receiver, was too thick or something. And it even looked as if the finish was beginning to wear/scratch off the handle in two particular spots where it was rubbing. I cleaned the latch and oiled it and it was slightly better, but still too stiff. I think it's the latch, not the bolt, but just wanted to get some ideas/confirmation. Replace the handle? If so, would PRI do for free?

2. Also, I bought some Black Hills 77gr ammo for the SPR and couldn't get the gun to run with it at all. When I'd insert a mag and release the bolt, the bolt would only run 3/4 of the way forward and would not seat the round, even when using the forward assist. I know it's a longer round, but I thought the mil-spec LMT 5.56 chamber was OK with this round? What could explain this?

3. Even after switching to 55gr surplus, I had numerous failures-to-feed. The bolt never picked up a round several times, and several other times it would strip a round out of the mag but not seat it (not sure what was going wrong here?), leaving me to eject a round with a big dent in the case halfway down. This hasn't happened to me before either.

4. Another observation I made (unrelated to the above?) was that I had great difficulty seating the magazines when the bolt was forward. This has never been a problem with my other ARs, but I didn't fight it and just inserted all my mags with the bolt back.

Thanks, guys, for any help here.

Will
Link Posted: 9/4/2004 9:21:56 PM EST
Link Posted: 9/5/2004 4:13:48 AM EST
Tweak,

I've never heard of an "adaptor pin", so yes, I'm using the standard Colt pivot pin.

I'm not sure of the answer to #2--what should I be looking for compared to my other ARs (another Colt MT6400C and an RRA LAR-15 M4gery)?

Yes, it is the PRI Gas Buster handle.

Yes, the bolt carrier moves freely when off the lower.

Any ideas? Thanks Tweak!

Will
Link Posted: 9/5/2004 4:31:16 AM EST
almost sounds like a bent gas tube(at the carrier end) or a bent carrier key......but the bolt carrier out and look at the key...should be perfectly round and make sure its not loose.......then turn the upper upside down and look at the gas tube where it comes in the upper...make sure its straight......and if you want to see if its the charging handle take the bolt and carrier out and then put the charging handle in by itself and see if its still tight that way.
Link Posted: 9/5/2004 5:11:27 AM EST
Link Posted: 9/5/2004 9:39:50 AM EST
OK, I took Paul's advice (thanks Paul) and sanded down the PRI latch's obvious rub points with a Dremel and it seems to have worked. Looks like I just need some Aluminum black and all will be OK.

So, one problem fixed.

As for the others, any ideas, or are they somehow related to the charging handle issue? I'm particularly concerned about the ammo issue, since the FTF problems could be attributed to some old GI surplus mags I was using.

Thanks again for the help.

Will
Link Posted: 9/5/2004 9:01:01 PM EST
Link Posted: 9/6/2004 2:45:25 PM EST
Tweak, OK, ya got me. Where the heck's the Glossary function here?

Will
Link Posted: 9/6/2004 3:15:04 PM EST
Link Posted: 9/7/2004 7:04:25 AM EST
Tweak, actually I made sure to read the tacks before posting, but I didn't see anything spoecifically labelled "glossary"--sorry. But I found the pics, and although I'm at work, I'm pretty sure that the LBC carrier is NOT slotted.

How does that affect your diagnosis?

Thanks.

Will
Link Posted: 9/7/2004 2:10:56 PM EST
Link Posted: 9/7/2004 3:30:15 PM EST
[Last Edit: 9/7/2004 3:31:51 PM EST by WillMunny]
Tweak, OK, I checked and the bolt carrier is NOT slotted. And both the gas tube and the carrier key check out OK to me--they fit together very snugly, but do not bind...any other ideas?

I'm really stumped as to why the 77 grain ammo wouldn't feed at all. Are there some uppers that this longer round WON'T work in? I was told it was an LMT upper, and have no reason to doubt the seller...

Will

Link Posted: 9/7/2004 8:40:20 PM EST
[Last Edit: 9/7/2004 8:41:30 PM EST by Tweak]
Top Top