Warning

 

Close

Confirm Action

Are you sure you wish to do this?

Confirm Cancel
Member Login

Posted: 12/1/2007 7:26:30 PM EDT
My ciener kit is binding when I pull the charging handle and the bolt remains stuck open. When I seperate the upper and lower the bolt returns forward. It seems to be binding on the hammer but I am not 100%. Any ideas?
Link Posted: 12/1/2007 7:27:46 PM EDT
Have you lubed up the carrier since you bought it?
Link Posted: 12/1/2007 7:38:56 PM EDT
[Last Edit: 12/1/2007 7:40:48 PM EDT by hunter121]
Yeah, cheak your hammer I bet it is just touching enough to stop it/hold it open. I can almost bet you have a stock trigger. I was having the same probloms when I got mine. I swapped the kit over to my other lower with a 2stage and it ran without a hiccup.

Also make sure everything was cleaned then lubed well like Yoteslaya was saying. Actually try that first before you take a dremel to the hammer.

Link Posted: 12/1/2007 8:53:29 PM EDT
Thanks for the tips. I will definately lube it up well. I've heard some reports that the ciener kit will not run with a two stage trigger because often times the hammer will not reset. Is there truth to this or did I misunderstand?
Link Posted: 12/1/2007 9:14:07 PM EDT
Try checking this thread out: rimfire link

wg
Link Posted: 12/1/2007 9:17:14 PM EDT

Originally Posted By WallyGator:
Try checking this thread out: rimfire link

wg


+1 thats my thread and Im having the same problem in my new upper. It worked just fine in my sabre defense upper and SP1 upper but this one will not let it seat right.
Link Posted: 12/2/2007 11:01:45 AM EDT
I'd say there's a 50% chance the problem is your charging handle. There are some charging handles which just don't seem to like Cieners. I switched charging handles (back to the original one that came with my RRA) and now it runs fine.
Link Posted: 12/2/2007 12:02:22 PM EDT

Originally Posted By disco_jon75:
I'd say there's a 50% chance the problem is your charging handle. There are some charging handles which just don't seem to like Cieners. I switched charging handles (back to the original one that came with my RRA) and now it runs fine.


unfortunately it isnt. Ive tried 3 now and it works in other upper with them but not in my current one either.
Link Posted: 12/2/2007 12:21:54 PM EDT
I have 2 Ceiner kits. Right now, I am running them in only one upper at the moment. One of them fits in the upper and works great. The other does what you described.

You pull the charging handle back, and the bolt sticks to the rear. But the charging handle moves freely. I don't have to seperate the upper from the lower though. I just start tapping the bolt with my finger and it wil fly forward.

Both are used in the same upper and lower combo. They both were polished. There must be some slight Q.C. issues? There's got to be some little thing that is slighty different between the 2 to cause it to bind. But I can't see what it is.
Link Posted: 12/2/2007 12:39:23 PM EDT

Originally Posted By RobertV77:
Thanks for the tips. I will definately lube it up well. I've heard some reports that the ciener kit will not run with a two stage trigger because often times the hammer will not reset. Is there truth to this or did I misunderstand?


I had a new Ceinar kit out for the first time yesterday in a lower with a RRA 2 stage. If I loaded the 10 round magazine fully, then sometimes it wouldn't reset the hammer after the first shot (and only after the first shot). I started loading only 9 rounds and it still happened a few times. I tried 8 rounds and it reset on every shot after that.

I haven't tried it with a standard trigger group yet.
Top Top