Warning

 

Close

Confirm Action

Are you sure you wish to do this?

Confirm Cancel
Member Login

Posted: 10/26/2013 1:40:37 PM EST
[Last Edit: 10/26/2013 2:05:24 PM EST by scottMO]
Ive bounced around on rail options and now use YHM quad rails. The problem now is that the lower rail is loose and has forward/rearward and some side to side movement to it and is very noticeable with a vert grip. I prev had a set of surefire rails on it which pushes rearward on the delta ring? Did this cause it? Is it the lower part of the delta ring that's lost it's tension due to the way the surefire rails add torque? Have i just not gotten the delta ring tight enough and it's not adding enough pressure on it? Or are the Yhm rails possibly the problem ? Could/should I shave a little off of the outside of the single rail to get the delta ring to move forward more?

Any suggestions?

I'd rather not go to a free float system on this upper.

right now the triple rail is on the left, top and right side, while the single rail is on the bottom. Can I flip these and put the loose single rail on top and the triple rail on the left, bottom and right? Would it fit? That didn't work as there is no gas tube cut out on the single rail
Link Posted: 10/29/2013 5:17:00 AM EST
Anybody?
Link Posted: 10/29/2013 6:36:15 AM EST
I don't have a set of those, but the only thing I can think of is that you don't have the top seated all way. That is preventing the delta ring from fully capturing the lower piece. Also, is it possible you have the lower installed backwards? I can't quite tell but it looks like you might be able to install it backwards.

Take them off the rifle and fit them together. They should mate perfectly and have no play between one another. Did you get them used? Perhaps the previous owner busted some alignment tabs or feature.
Top Top