Warning

 

Close

Confirm Action

Are you sure you wish to do this?

Confirm Cancel
Member Login
Posted: 10/14/2004 6:33:51 PM EST
Anybody else have experience with this? Tried them in an Oly and Armalite lower. Is this normal?
Link Posted: 10/14/2004 7:57:26 PM EST
In two RRA lowers, all four of my PRI mags drop free when empty.

In my old Eagle Arms lower, the two PRI mags I painted with AHII do not drop free empty, but the two which are "stock" drop free.

Link Posted: 10/14/2004 8:11:13 PM EST
Link Posted: 10/14/2004 8:24:45 PM EST

Originally Posted By Lumpy196:
You need a 6.8 lower



Link Posted: 10/15/2004 7:10:02 AM EST
I had the same problem... I spoke to Sean at PRI and he told me to try tofind out where the mag was catching in the magwell and to take a Vise or pliers and gently push the raised spot(s) down. I did this and they work great now.

Link Posted: 10/15/2004 10:29:09 PM EST

Originally Posted By saojao:
I had the same problem... I spoke to Sean at PRI and he told me to try tofind out where the mag was catching in the magwell and to take a Vise or pliers and gently push the raised spot(s) down. I did this and they work great now.




I'll try that.
Link Posted: 10/16/2004 3:20:43 AM EST

Originally Posted By Combat_Jack:
Anybody else have experience with this? Tried them in an Oly and Armalite lower. Is this normal?



With all my Colt lowers & BM lower, they drop free.

Zak, any up date on you modified Magpul followers? I haven't had any issues with my PRI mags, but I don't consider I have enough rounds down range yet for a definitive opinion.
Link Posted: 10/16/2004 1:53:46 PM EST
pcurtis,

I have no new data since my last update to that other thread, except that they continue to work with no malfucntions.

The newer (more stiff) PRI followers work better than their original ones, too.

-z
Top Top