Warning

 

Close

Confirm Action

Are you sure you wish to do this?

Confirm Cancel
PSA
Member Login

Posted: 6/22/2017 10:34:09 AM EDT
Got my MPX yesterday. Got it home, total disassembly, cleaned it (piston, barrel BCG, Trigger) and lubed it. Went to the range today with 500 rounds. Mostly Fiochi 124 and 115 grain and some CCI Blazer Brass 115gr.

1st mag full was awful, FTF, double feed, jams, got a shot off and FTE. So I checked everything and it all looked good. I unloaded the mag 1/2 way and it would fire a few and either stove pipe or FTE, cleared, then a few more off and a double feed.

This went on for around 100 rounds. It would cycle better if loaded to 10 rounds. Then around 175 rounds at 10 round mag load on the 30 round mag it cycled perfectly...so I would up it to 15 rounds in the mag and work that.

Finally after around 250ish rounds I could run through 20 rounds in the 30 round mag no problem. So I upped it to full 30 rounds. Sometimes it would feed the 1st round sometimes not.

Then around 325-340 round it started feeding a full mag no problem. from 350 rounds to 500 round zero issues...perfect running MPX.
I have 4 more mags on order and they should be here in a couple days. I am thinking it was mostly a mag issue because I noticed by the time I got to around 300 rounds the mag seemed easier to load and to just push bullets out with my thumb too.

I hope I don't have to go through 500 rounds per mag just to get the mags to work...LOL
Also the iron sights...spot on..I was ready to adjust with sight tool but nothing needed...WOW! Target was on pistol range at 25 yards..standing no rest.

I am still confused if its legal to shoulder this pistol. I'm a big guy 6'6" 225lbs and I can cheek weed it but brace is not into my shoulder.

I have photos but can't insert them from my computer on the forum...
Link Posted: 6/22/2017 8:04:59 PM EDT
Leave the mags that you have loaded for a little while. If you buy a 3 pack for$60 just load all of them (shorten the follower spike and they hold 35 rds) then let them sit for a few weeks. I had a few similar problems with mine when I got it. The mags I had left loaded for 2 weeks worked perfectly. The brand new mags I brought with had repeated failures. After leaving the mags loaded, they now are all perfect. just needed time to "settle" the spring.
Link Posted: 6/22/2017 8:27:37 PM EDT
Link Posted: 6/22/2017 9:11:05 PM EDT
Attachment Attached File

Here's a pic for the OP.
Link Posted: 6/23/2017 9:23:26 PM EDT
[Last Edit: 6/23/2017 9:26:32 PM EDT by mdrums]
Humm...never saw that sub forum...you're correct it belongs there.....when I pull up ar15.com and click menu for th forums I don't see the Sig forum though.

Can the Admins please move this thread to the Sig forum as that's were this belongs....thanks!
Top Top