Warning

 

Close

Confirm Action

Are you sure you wish to do this?

Confirm Cancel
Member Login
Site Notices
9/22/2017 12:11:25 AM
Posted: 8/18/2005 9:58:36 AM EDT
I recently had a problem with a bolt on my BM A2. Thanks to all of help from this board I was able to clear that up. Unfortunately last night I had my other BM at the range and am now having problems with that. The bolt doesn’t move after taking a shot. The spent casing has to be removed by pulling the charge handle. If effect it has become a bolt action. I had the Ace stock off last week and was thinking that I may have done something during dismantling. If any anyone has had similar problems or may know the cause I would greatly appreciate it.

Thanks
Link Posted: 8/18/2005 10:02:52 AM EDT
Inspect your gas rings. Do you use anything to clean your gas tube like a pipe cleaner? Hope not.
Link Posted: 8/18/2005 10:04:09 AM EDT
Check gas rings to see if you have staggered correctly. Definitely sounds like gas is linking by though.
Link Posted: 8/18/2005 10:08:53 AM EDT
[Last Edit: 8/18/2005 10:10:19 AM EDT by highwayman]
Hmm, sounds like you have a gas problem. Sorry, had to do that. If your bolt isn't moving then gas isn't getting to the gas key. You may have an obstructed or broken gas tube. You could also have a REALLY loose carrier key. Also, you might have an obstructed gas port. Just some other ideas. MJD
Link Posted: 8/18/2005 12:11:31 PM EDT
The tube is clear. I just swapped out the bolt from my other BM and worked fine. It appears that the the new complete carrier may have some issues.
Top Top