Warning

 

Close

Confirm Action

Are you sure you wish to do this?

Confirm Cancel
Member Login
Site Notices
11/22/2017 10:05:29 PM
Posted: 10/28/2004 8:28:58 PM EST
Tried my new AR at the range today. RRA lower, M&A parts kit w/ 20" heavy bbl. Shooting Maine 55gr FMJ. Many problems. Main problem is failure to feed when releasing bolt on the first round, but apparently only if there are an even number of rounds in mag. Tried 2-3 USGI mags out w/ the same result. Also had 1 or 2 FTFs in the middle of mags. Bolt hold also doesn't work consistently (mostly works but not always). Any idea what's wrong?

I bought this as a (barely) used rifle from a private party. Rifle has about 75 rounds total through it (including the 73 I shot today). I don't plan on keeping anything but the stripped lower (have an LMT upper and Colt guts on the way) but I also don't want to pass on a lemon to the next guy. Should I try to fix it, part it out, or sell it as is?

On the up side, my M1A purred like a kitten, as usual
Link Posted: 10/28/2004 8:42:28 PM EST
Repost this in the troubleshooting forum.

How was the rifle lubricated?
Link Posted: 10/28/2004 9:41:26 PM EST
how about the ammo?
Link Posted: 10/28/2004 10:16:07 PM EST
Rifle was lubed fairly well, though I'm not sure if/where bolt carrier assembly should be greased. I didn't lube it myself since the previous owner obviously had.

Ammo is Maine 55gr FMJ. Should have tried some of the other stuff I brought, but decided to forget about the AR and have fun with the M1A, my favorite rifle bar none. Maine isn't top grade, but it shoots well enough in my Mini, better than some brands I've tried.
Link Posted: 10/28/2004 11:21:33 PM EST
[Last Edit: 10/28/2004 11:22:59 PM EST by Tweak]
Top Top