Confirm Action

Are you sure you wish to do this?

Confirm Cancel
Member Login
Site Notices
1/25/2018 7:38:29 AM
Posted: 10/18/2002 7:34:14 PM EST
I am building a lower for the first time and I am running into an issue. So far everything has been great but the pin used to lock the bar underneath the trigger is too big for the hole. I also have the same issue on the part that locks the bolt back. I don't have any other pins left so this is all I have. I am using an Olympic Arms lower.
Link Posted: 10/18/2002 7:51:50 PM EST
I built one that had a parkerized lower and a couple of the holes had some crud or slag like material that I cleaned out with a twist drill bit held in my hand(no motor). Is there another receiver you could compare to yours?
Link Posted: 10/19/2002 3:30:07 AM EST
Unfortunately, no. I sold my old one years ago. My receiver looks to be perfectly made with no excess metal.
Link Posted: 10/19/2002 3:59:33 AM EST
Have you tried to lightly tap the pins in with a small hammer or a plastic hammer? I don't mean to just haul off and whop it real hard but lightly tap it and see if they will start to go.
Maybe get some other pins and see if they are the same. If the holes are out of spec you might have to ream them a little but be careful.
Link Posted: 10/19/2002 4:51:57 AM EST
I had the same problem with the last lower I built (RRA with Bushy internals) all I did was to thin them out just a bit with a file (just a few passes with no real pressure) and then used an aligator pliers (spell?) to get them started and then tapped them with my 3lbs. hammer (I do not have a small one). Whatever you do go really easy and do not force anythin or you will scratch your lower and regret it the rest of your life.
Good luck

Link Posted: 11/5/2002 7:23:39 AM EST
I had a simualr problem trying to improvise tools, using a Oly lower but after breaking down and getting a set of Role Pin Punches the problem was solved
Hope this helps
Link Posted: 11/5/2002 8:03:29 AM EST
[Last Edit: 11/5/2002 8:04:17 AM EST by LarryLove]
I'm having that problem right now and posted this question a few days ago:

Top Top