Warning

 

Close

Confirm Action

Are you sure you wish to do this?

Confirm Cancel
Member Login
Posted: 10/5/2004 12:42:00 PM EDT
[Last Edit: 10/5/2004 12:46:32 PM EDT by 1-75Ranger]
I bought a LMT/Lauer lower and used a parts kit from J&T Dist for the build. The only problem I am having is when I move the safety selector to the fire position it does not line up at a 90 deg angle (i.e. the point on the selector is not pointing straight up). The tip lines up more with the I in FIRE then straight up and down. Also when I place it in the FIRE position, there is not a solid feel to it and it does not click at all. Now when I move it to the SAFE position it does click and make a more solid feel.

Is this normal or did I install something a little out of alignment, the safty does work as far as placeing the weapon on safe and I have done a function check and that works ok also.

Any ideas?
Link Posted: 10/5/2004 12:48:22 PM EDT
[Last Edit: 10/5/2004 12:48:35 PM EDT by Feedingcannibal]
I have the same build. IMHO, if it works, don´t worry about whether it clicks into place or is absolutely vertical.
Link Posted: 10/5/2004 2:45:54 PM EDT
I used rock river internals on mine and it lines up and clicks like my issue on e does.
Link Posted: 10/6/2004 3:01:13 PM EDT
I agree with Jimbo. I used a RRA LPK and mine stops perfect and has a positive click.
Link Posted: 10/6/2004 3:11:15 PM EDT
It doesnt matter where it points, but it should click into and out of place. This is a safety feature, so the safety doesn't come off.
Top Top