Warning

 

Close

Confirm Action

Are you sure you wish to do this?

Confirm Cancel
Member Login

Site Notices
12/6/2019 7:27:02 PM
Posted: 10/2/2011 2:40:22 PM EST
[Last Edit: 10/3/2011 12:00:33 PM EST by Murphy123]
I have a what I perceive to be a problem with my Leupold VX-R Patrol w/FireDot:

Here's the deal:

Several weeks ago I ordered the above scope off the web. Good scope except for one thing. If I understand correctly from Leupold's literature, you can set the dot on ANY brightness, lay the scope down for 5 minutes and then when you pick the scope back up, it will "wake up" at that same setting. The scope I ordered would not do that. It came back on WAY dimmer. I called Leupold, the tech said yeah, it should come back on with the same brightness. Not wanting to send a brand new scope back to Leupold, I sent the scope back (with full disclosure) to the vendor for a refund.

I liked the scope so much (except for the above problem) that I ordered another one from another source expecting "No problems". Well, the second scope does the same thing. Am I missing something here? I would appreciate any input from anyone familiar with this scope as to what their experiences are.
Link Posted: 10/2/2011 5:25:29 PM EST
That realy sucks to hear

I was really looking into putting one on a hunting rig.

Have you notified Leupold about the second one?
Link Posted: 10/2/2011 5:37:11 PM EST
Yeah, I sent an e-mail, but the guy is out of the office until Tuesday. Guess I'll find out more then. Hopefully someone on the forum with "hands-on" experience will respond. It really is a nice scope; just can't figure out what's going on with the Motion Sensor feature.

It just seems incredible coincidence that it's happened on two different scopes from two different dealers.
Link Posted: 10/3/2011 12:07:11 PM EST
I talked to a tech guy today at Leupold and explained the details of my problem with the two Leupold Patrol Firedots (1.25-4).

He consulted with an engineer and came back on the line to tell me that they had been aware of the malfunction for a few weeks now and were working on a solution.

Just wanted to let you guys know.

Murphy123
Top Top