Warning

 

Close

Confirm Action

Are you sure you wish to do this?

Confirm Cancel
Member Login

Site Notices
Posted: 1/23/2008 3:22:34 AM EST
I have two dedicated .22 uppers:

The first one is Keuhl upper with 11.5" barrel and it runs on a DIAS host. It has had about 10,000rds through it and runs like a top, I clean it about every 2,000rds. Yesterday it was so dirty that during mag dumps the ROF started slow and sped up as the magazine emptied. I always ran it with Ceiner mags but now have some BDM mags and it still works perfectly. Keuhl replaces the entire chamber adaptor on his kit, the bolt closes directly on the purpose-built .22 barrel and feedramp. I have changed NOTHING on this kit, it worked like this from new.

The second kit is a Spikes 8" upper running on a Colt M16 lower with the same Ceiner kit except Spike retains the piece of the 5.56 chamber adaptor with the feed ramp. The bolt closes on the barrel and an 'outer ring' of the chamber adaptor that has the feed ramp machined as part of it. When I first got it it ran perfectly from Ceiner mags. When I used BDM mags I had many FTFs so I reamed the chamber to Bentz specs and ramped the barrel a bit, it now feeds perfectly. In semi-auto it runs perfectly, in FA I get the hammer down on a closed bolt and dead trigger. I also had one OOB discharge.

I'm thinking the Spike bolt is bouncing now that the kit is 'broken in' and loosened up. How can I be sure that is the problem and what is the easiest way to solve it?

TIA.
Link Posted: 1/23/2008 4:03:25 AM EST
Stick this in the rimfire section.
Link Posted: 1/23/2008 4:22:05 AM EST

Originally Posted By orkan:
Stick this in the rimfire section.


OOPS! I thought I did.
Top Top