Warning

 

Close

Confirm Action

Are you sure you wish to do this?

Confirm Cancel
PSA
Member Login

Site Notices
Posted: 7/19/2010 3:52:06 PM EDT
Good evening gents, just wanted to check in and see if anyone else has noticed this w/ their MAD.  It looks and feels uneven.  I emailed GG&G and they said
"It is canted on the top of the base only. The stem sits square to the bore and the female dovetails are square to the uppers male dovetails"
I then took these pics and sent them to them on 06/09/10 but have not received a response since.  







To me, it looks like the whole thing is canted but I guess I may be going crazy.  At any rate has anyone noticed this on theirs at all?  I've tried it on many rails on several guns w/ the same results, so it is not the rail.  
TO BE CLEAR, I'M IN NO WAY BASHING GG&G, I'm just looking for clarification as I did not receive a response to my last email containing pictures.  Any input would be appreciated.
Link Posted: 7/19/2010 5:38:25 PM EDT
I'll check mine but no - mine sets fine AFAIK.
Link Posted: 7/19/2010 8:56:52 PM EDT
Thanks I look forward to your response.  I hope something can be done because I love the sight and how low profile it is but the crookedness will bug me whether it's supposed to be there or not.
Link Posted: 7/19/2010 9:11:44 PM EDT
i dont have on but that def looks a little off
Link Posted: 7/19/2010 9:17:48 PM EDT
mine doesnt look like that. i would say something is wrong there
Link Posted: 7/19/2010 11:35:44 PM EDT
Definitely off. I would contact them again. Ask them to make it right.
Link Posted: 7/19/2010 11:40:42 PM EDT
Does not look right.
Link Posted: 7/19/2010 11:53:50 PM EDT
Don't have that model, but yours looks funny.

in before...
Link Posted: 7/20/2010 2:30:29 AM EDT
try flipping the left side where it bites into the upper and the sight... sometimes they flip around and you have the wrong side up...

I have 3-4 of these (and one on my work rig) and I really like them for a rear sight.
Link Posted: 7/20/2010 3:04:14 AM EDT
Originally Posted By marinesg1012:
try flipping the left side where it bites into the upper and the sight... sometimes they flip around and you have the wrong side up...

I have 3-4 of these (and one on my work rig) and I really like them for a rear sight.


Look real close and the way it's made there is not enough space left to make that happen.  Flip it and you will wind up short of the rail by a good margin.

Good idea - which I thought of - and then look at the dimensions.

OP - mine sets fine.  Have you another rear to test on the upper?

It is either the sight or the receiver - hopefully the sight as it's easier to fix.

I'd contact GGG and send the photo.  They are good people.
Link Posted: 7/20/2010 8:19:26 AM EDT
Mine sits perfectly flat and is straight when deployed- definately something wrong. Are you sure it's not a clone of the MAD sight there are many around?
Link Posted: 7/20/2010 8:35:32 AM EDT
Typically the clones don't lock in the up position.  Ask me how I know
Link Posted: 7/20/2010 12:30:51 PM EDT
I appreciate all the input, I've sent another email to them and hopefully I can get it resolved this time around.
Link Posted: 7/20/2010 2:39:38 PM EDT
Just link them to this thread.  Like I said - they are good people!

No other rear BUIS to try and make sure it is the sight and not the receiver?

Move it to another spot and see if the bolt clamping it is not binding or setting up out of the groove?
Link Posted: 7/22/2010 8:13:28 AM EDT
They said send it in and they'll take care of it, can't complain about that.  Again, thanks for the input guys.
Top Top