Warning

 

Close

Confirm Action

Are you sure you wish to do this?

Confirm Cancel
Member Login
Site Notices
1/25/2018 7:38:29 AM
Posted: 6/24/2003 10:10:44 AM EST
First I tried swapping out the firing pin spring for a much stronger spring, but that didn't help.

I removed the telestock and replaced it with an A2 stock, buffer and spring. The problem seems to have stopped occurring.

I am still not certain what the root cause is / was, but at this point I'm just happy to have made the problem go away.
Link Posted: 6/24/2003 10:15:38 AM EST
Was it consistantly doubling, or was it sporadic?
Link Posted: 6/24/2003 10:16:10 AM EST
It is a mystery. I just flipped my firing spring around and it stopped. Am happy but still wonder if this was my problem.
Link Posted: 6/24/2003 11:25:24 AM EST
It might double or triple 3 or 4 times in the course of 20 rounds.
Link Posted: 6/24/2003 5:16:07 PM EST
I've always used rifle length buffer tubes and a standard rifle buffer in my Olympic 9mm. Still I would think the Olmpic 9 should be able to run with the short buffer tube and buffer. Were you using a heavy 9mm buffer or standard carbine buffer with the telestock?
Link Posted: 6/24/2003 7:10:25 PM EST
It's the standard carbine buffer & spring.
Link Posted: 6/24/2003 7:22:12 PM EST
I guess it'll be a mystery problem. Glad you got it going better though.
Link Posted: 7/8/2003 8:08:43 AM EST
I recently was cleaning my oly and was checking out the spring bar that runs across the upper by ejection port the metal bar sticks up and rub against the bolt. I believe this is to slow bolt down when returning to chamber. I bent it a little farther up and have not had a doubling since. hope this helps
Top Top