Warning

 

Close

Confirm Action

Are you sure you wish to do this?

Confirm Cancel
Member Login

Site Notices
Posted: 3/14/2005 10:32:28 PM EST
It was working yesterday, today it isn't. It hasn't even left the house. I tried several sets of new batteries, no fix. It isn't accidentally in NV mode, I'm sure of that. It just stopped working. It's only a month old. No signs of damage, it's mint.

Anyone else had an EOTech 552 just stop working?
Link Posted: 3/15/2005 4:42:21 PM EST
Link Posted: 3/16/2005 7:16:43 AM EST

Originally Posted By Boom:
Call EOtech.



+1. They'll take care of you.
Link Posted: 3/16/2005 8:45:21 AM EST
I'll call them asap. Thanks.
Link Posted: 3/16/2005 8:52:00 AM EST
Remove the battery carrier and reinstall it. I had this issue with one the day after i got it. Somehow the battery holder was not all the way installed and it wasnt getting a good conection. There is a seal about 1/8' thick that the cover slides over as you actuate the lever and the battery holder was getting hung up on it. Havent had the issue since.
Link Posted: 3/16/2005 9:02:23 AM EST
I had a similar problem with my older 551 about a month ago. Went thru the same drill as you. Finally emailed EOTech and they offered some ideas. When none of that worked, they said send it in.
Got a new 551 back from them in a bit under 2 weeks! Awesome service! They will make it right one way or another!
Oilfieldtrash
Link Posted: 3/17/2005 11:15:02 AM EST
Turns out that I just had a whole batch of brand new batteries that were dead from the store. Before I called EOTech, I wanted to be sure it wasn't something as dumb as that, so I picked up a 2 pack from the corner store and sure enough, it lit up.

Top Top