Warning

 

Close

Confirm Action

Are you sure you wish to do this?

Confirm Cancel
PSA
Member Login

Site Notices
9/17/2020 5:59:48 PM
Posted: 3/8/2010 4:31:04 PM EDT
I've got an Eotech 552. I bought it new a couple of years ago. I have it on one of my AR's and took it out for the first time in a year and I couldn't see the dot or ring in the sun. I turned it all the way up which I could see in the shade but the minute I pointed the rifle down range in the sun I couldn't see it. I changed the batts and it's not on NV. I noticed if I turn it on in a really dark room you have to turn it up 2 clicks to just see the ring/dot, when you first turn it on you cant see a thing even in a dimly lit room. Is this normal? I remember I could see the ring/dot in the sun when I first got it but just barley with it turned all the way up. I remember thinking , they use these in the desert!? I can barley see this thing, but now I can't see it at all in the sun. I called eotech twice today and left a message for Customer Service but didn't get a call back The thing that really sucks is I don't have 20 hours on this effing thing!! Can anyone chime in on how bright theirs is. TIA
Link Posted: 3/8/2010 4:36:10 PM EDT
Try changing the batteries.  Then turn it up about five or six clicks and see if that helps.  You should be able to see the ring and dot.

Hopefully you don't have a clone.
Link Posted: 3/8/2010 4:57:50 PM EDT
[Last Edit: 3/8/2010 5:42:01 PM EDT by Tomac]
My Eotechs have all been very bright when first turned on. Since yours was sitting unused for so long (was it stored w/batteries in it? If so, were they alkaline?) I suggest you take a rubber eraser and/or contact cleaner and go over the battery springs and contacts then try it again. Definitely check w/Eotech, I hope you don't have a clone!
HTH, keep us posted...
Tomac
Link Posted: 3/8/2010 5:15:16 PM EDT
Clone. Crap I hope not. It came in a Eotech box w/papers. It's labeled Eotech. I tried new batts, litiums too, but no help, didn't store it with the batts. When I first turn it on you can't see the ring even in a dark room, you've got to click it up 2 or 3 clicks to see it. I'll keep calling Eotech. I don't have the receipt and it's labeled mfg April 2006 so I wonder how they will handle it. Like I said this thing looks brand new and has less than 20 hrs on it.
Link Posted: 3/8/2010 5:43:10 PM EDT
Link Posted: 3/8/2010 6:00:10 PM EDT
Thanks Tomac. From what I can see mine is legit, just defective. Anyone have experience with Eotech CS?
Link Posted: 3/8/2010 6:08:47 PM EDT
yeah mine wouldnt hold zero and couldnt be zeroed got sent back they reglued something inside and sent it back it works but aimpoint is best
Link Posted: 3/8/2010 6:31:27 PM EDT
Originally Posted By skytrooper603:
Thanks Tomac. From what I can see mine is legit, just defective. Anyone have experience with Eotech CS?


You're welcome. I've never had to use Eotech's CS but from what I've heard it's good. Try cleaning the battery springs/contacts and see if that helps.
Tomac

Link Posted: 3/8/2010 6:31:53 PM EDT
Are the batteries from back when you bought the Eotech, or are they brand new?
Link Posted: 3/8/2010 6:37:03 PM EDT
Originally Posted By pavlovwolf:
Are the batteries from back when you bought the Eotech, or are they brand new?



Brand new. I tried 3 sets, 3rd set was Lithium.
Link Posted: 3/8/2010 7:03:59 PM EDT
I think their CS is pretty good these days.  There was a time they were understaffed for the job, so some folks might report that, but I think it is out of date info.
Link Posted: 3/8/2010 7:20:43 PM EDT
would you care to disclose the source of the purchase? cabela's,any one of the board vendors,...etc. not an attempt to slam the place you bought it from,it just may shed a little more light as to the authenticity of the eotech. this very issue is the reason i bought from my own personal favorite source for shooting equipment/supplies,....cabela's. their c.s. is second to none.<shameless plug>
Link Posted: 3/9/2010 1:12:36 AM EDT
[Last Edit: 3/9/2010 1:28:25 PM EDT by skytrooper603]
........................
Link Posted: 3/9/2010 3:23:15 AM EDT
I would say your unit is damaged. I had mine out in full sunlight 1pm, with a snow covered shooting range (about as bright as it gets lol). I never put the Eotech on more than it's mid range brightness and the circle and dot are very easy for me to see. Here's a pic showing what I mean (not the best pic but the reticle is crystal clear to my eye when looking through it).

Link Posted: 3/9/2010 3:41:15 AM EDT
Here's the obligatory "shoulda gotten an Aimpoint."

Having said that, My limited experiences with EOTech CS have been good.  Good luck!
Link Posted: 3/9/2010 4:19:15 AM EDT
EOTech CS is good.  However, there is only a two year warranty.  So they may charge you to fix it.
Link Posted: 3/9/2010 4:22:24 AM EDT
The EOTech CS will make it it right! As for the "shoulda got an Aimpoint"...I have news for you. This may come as a huge shock but...yes...you guessed it...they have issues as well. For whatever reason this forum always seems to be some what anti-EOTech and very pro Aimpoint. Both are mechanical and both will experience mechanical issues.
Link Posted: 3/9/2010 1:22:03 PM EDT
OK here's the latest. Spoke to Mike in repairs at Eotech. I described what it was doing and he knew right off what the problem was. He says that the seal on my unit has let go. Seems they are charged with nitrogen and sealed. This somehow leads to deterioration of the coating on the lens. Anyway he said to send it in and they'll fix it up no charge. AA++ for Eotech customer service.
Top Top