Warning

 

Close

Confirm Action

Are you sure you wish to do this?

Confirm Cancel
Member Login
Site Notices
9/19/2017 7:27:10 PM
Posted: 9/2/2002 11:45:33 AM EDT
I've added both a green follower and new USGI springs to a couple of my mags and am still having some FTL's with them. It's not every round, usually 2-3 per mag. I can't see anything on the lip that might be catching the round, they look just like the rest of my mags that function flawlessly. Anything else I can try?
Link Posted: 9/2/2002 2:25:53 PM EDT
Link Posted: 9/2/2002 3:07:50 PM EDT
The follower does go up and down smoothly. It seems to always be on the first round, the 10th round and another one about 25 or 26. I had one round yesterday where the bullet had almost been pushed all the way back into the brass. The feed failure is that the round is just not clearing the mag. I have to pull the charging handle back and then release it again in order to pick up the round. Thanks for the help!!
Link Posted: 9/3/2002 11:40:23 AM EDT
Link Posted: 9/3/2002 2:10:47 PM EDT
I had a similar problem recently with a beat-up ol' mag. The curved area where the feed lips meet the back "spine" of the mag was slightly distorted. The more rounds the thing was loaded with, the rounds would start to "nose down" and barely clear the front edge of the mag. After fifteen or so rounds loaded, releasing the bolt would cause the rounds to slam into the barrel extension and push the bullet back into the case.

I managed to sorta fix this one with needle nose pliers, but I'll gladly crush and save this mag when somebody starts selling replacement pre-ban mag bodies.
Top Top