Confirm Action

Are you sure you wish to do this?

Confirm Cancel
Member Login
Posted: 4/7/2012 9:34:10 PM EDT
I bought a new REC - 7 (5.56) a week ago, but I am having a problem with it. Every time I rack the bolt it jams. It seems like the nose of the round that I'm trying to chamber is getting stuck on the locking lug cutouts above the feed ramp. I have had the bolt carrier apart for lubrication. I thought it may have been possible that I assembled it incorrectly, but I've looked at it numerous times and don't see anything wrong with it. I have also tried my bolt in my friends rifle and it functioned fine with no problems. I can get the rifle to chamber by racking the bolt an additional time. The spent case seems to eject fine.
The problem seemed to start when I was sighting in the rifle. Everything was working correctly and I had no problems chambering rounds. Though I only had three in at a time ("range rules"). I fired a magazines worth of rounds with no problems. Part way through the second magazine it got caught like it does when I rack the bolt now. I had no problems chambering rounds before this. I'm not sure what the problem is as it is a brand new rifle. I am using P-mags and PMC .223 bronze so I don't think it is the magazines or ammunition. Any help would be much appreciated.

Here is the best picture I could get:
Link Posted: 4/8/2012 2:32:06 PM EDT
[Last Edit: 4/8/2012 2:36:00 PM EDT by Dano523]
Link Posted: 4/9/2012 6:02:22 AM EDT
I had the same problem with my PSA m4 using PMC 223 55 gr. Switched to Federal XM193 and Federal 223 55 gr. and it worked like a champ with no problems at all.
Link Posted: 4/9/2012 9:28:03 AM EDT
[Last Edit: 4/9/2012 9:28:40 AM EDT by Krieg]
Thank you both for your quick replies. I believe I figured out what the problem was. It was the rough edges (I'm guessing from machining) on the locking lug cutouts that were catching the rounds. I gently went over them with a needle file and now the rifle is running with no problems.
Top Top