Warning

 

Close

Confirm Action

Are you sure you wish to do this?

Confirm Cancel
PSA
Member Login

Site Notices
Posted: 5/1/2009 1:47:44 PM EDT
I've got a new CMT bolt in question, when it's in battery (assembled in a bolt carrier of course) on the rifle, it's quite tough to pull the charging handle back on the first try, there's major drag.  Especially if it's been sitting for a few minutes, yes minutes.  However once I pass the initial pull, it gets easier with follow up pulls, but if I let it sit for a few minutes, then it starts all over again.  Perhaps it's slightly out of spec?  Or just a tight tolerance?   Anyway, w/ a new RRA bolt, there are NO issues.  Both barrel and bolts are brand new, never shot.

Thanks!
Link Posted: 5/1/2009 2:09:01 PM EDT
[Last Edit: 5/1/2009 2:09:54 PM EDT by SSeric02]
B/c after the first time you charge it (pull it to the rear using the charging handle), you've cocked the hammer?

Have you cleaned it?  Lubricated it?
Link Posted: 5/1/2009 3:39:31 PM EDT
Yes, I know you cock the hammer the first time.  I've left the hammer cocked, come back to charge it, same thing.  Something is dragging, or binding pretty good.  Just wondering if anyone else has had this issue w/ a CMT bolt, perhaps a bad batch or something.

Yes, cleaned and lubed!  The RRA bolt as no issues!
Link Posted: 5/1/2009 3:53:08 PM EDT
Hmmm, could just be the gas rings on the CMT are tighter inside the bolt carrier than those on the RRA BCG.  

But, look at it to see if there is any abnormal scratches or finish wear in places that don't normally have finish wear on the bolt, carrier, and inside the upper.
Top Top