Warning

 

Close

Confirm Action

Are you sure you wish to do this?

Confirm Cancel
Member Login
Site Notices
10/20/2017 1:01:18 AM
9/22/2017 12:11:25 AM
Posted: 8/1/2005 9:41:32 AM EDT
[Last Edit: 8/1/2005 10:44:07 AM EDT by nobody-really]
I was wondering if anyone out there knows of any problems with the feed ramps on Bushmaster 97S pistols. Right out of the box mine had feeding issues. The bullet in the cartridge would wedge itself on the high profile of the ramp just as the cartridge was leaving the magazine, the high side of the channel on the feed ramp would dig itself into the bullet. When I compare the feed ramp in the 97S to other feed ramps it has very deep channels and is very different in shape, even to other carbon 15 models. This was happening 1 to 3 times a magazine.

Last time out I sprayed a ton of CLP on the ramp and only had one miss feed per 200 rounds, but I would like to get to the real problem not just hose my guns internals with CLP every time I want to shoot.

Now I did add a collapsible stock (don’t worry, it’s NFA) and also a spring and buffer from LMT, but I would not think that would be the problem.

Someone told me Bushmaster put out some bad feed ramps and they were being replaced.

Anyone know anything about the feeding problem or bad feed ramps?
Link Posted: 8/1/2005 11:08:24 AM EDT
[Last Edit: 8/1/2005 11:35:09 AM EDT by nobody-really]
OK, I called Bushmaster tech support / gunsmith and I was told that can be fixed by rounding out the sharp edges of the feed ramp and that that would be covered under warranty. I knew that would fix it and that was going to be my next course of action. I had already purchased a bullet shaped buffing wheel and some buffing compound. I've heard of too many people who go to town with a Dremmel tool and ruin what only needed a little polishing. So I figured a little work with some compound to remove any burrs and avoid a hack job.

Guess I’ll ship it out as it IS free.
Link Posted: 8/1/2005 12:55:10 PM EDT
Send it back!!!

I had some initial feed ramp issues with my Bushy, and I am talking about FTF like every other round. It was bad. I cleaned it and changed ammo, and the problem still persisted.

I explained it to Bushy and they emailed me an overnight UPS label and I had it back in a week.

It functions 100% now.

They added a D fender looking thing to the extractor, polished the ramps, and kinda cut in m4 looking feed ramps.

I am a happy camper at nearly 500 rounds fired without a failure. I even did a 120 round rapid fire stress test.

It was kinda hot to handle (thank god I put on para cord on the handguards)

I love it, I really really love it.

I just got a nice, bright reflex scope and I have some 68-77 grain "I mean business" ammo that WILL fragment out of the 7.5 inch barrel.

You have a pretty mean PDW there.
Link Posted: 8/1/2005 3:02:54 PM EDT
[Last Edit: 8/1/2005 3:06:22 PM EDT by nobody-really]
Thanks for the info. I'm going to send it back just got the RMA#. What ammo are you talking about??? Black Hills?? Soft Point???

I shot some 55gr UMC Wallmart green box and it was about 2200fps to 2300fps at about 5 yards. That's about 800fps to 1000fps lower then from a 16 or 18 inch barrel.
Link Posted: 8/1/2005 6:28:37 PM EDT
I tried some WWB 62 grain and some Lake City 55 grain before I called it quits and sent it back.

For my home defense supply, I have black hills 68-77 grain stuff
Link Posted: 8/2/2005 7:29:32 PM EDT
I was having the same problem with my 97.At first though,new gun needs breaking in.Then it started getting worse and worse>tyred sifferent mags and all sorts of ammo,but still hanging up.Sent it back to BM 2 tuesday ago,got it back thursday,went to the range,racked off just bout 400 rnds,then did a 90rd stress test and not a single hang up.BM just polished the ramps and chamber and she`s back 100%.
Link Posted: 8/3/2005 8:45:19 AM EDT
Well that’s good to hear, and encouraging. So they just polished the feed ramp and didn’t change the profile too much?
Link Posted: 8/3/2005 7:30:32 PM EDT
Yep,just the ramps and chamber and realy i can`t tell a difference before and after,just hat it doesn`t jam like it was.BM put 20 rnds through it and said it was all good and so far its been going 100%.I`m going to get out friday*weather permiting*or sunday and put a few more hundred through her.I say that BM customer service is damm good.
Link Posted: 8/19/2005 5:36:35 AM EDT
[Last Edit: 8/19/2005 5:37:13 AM EDT by nobody-really]
Well, I got it back and the feed ramp looks very different. It looks now like other AR’s I have seen. They returned it very quick. I still have to assemble it (I asked that it be returned disassembled so I could have the barrel threaded.) When I put it back together and fire it I will update the post.
Top Top