Warning

 

Close

Confirm Action

Are you sure you wish to do this?

Confirm Cancel
Member Login
Site Notices
Posted: 10/20/2004 8:02:32 PM EST
[Last Edit: 10/21/2004 5:33:51 PM EST by lippo]
When my bolt carrier locks back, it does not lock back on the bolt face, it locks back on the lower lip of the bolt carrier. The bolt carrier hangs up when I pull the charging handle back and I can't get the bolt/bolt carrier far enough back for it to lock up on the bolt face. Before going into a detailed strip and inspection. Anyone have a problem like this before?

I think it's hitting the buffer retainer pin and that's what's keeping it from going all the way back. Or could it be that it's hitting the hammer?



Link Posted: 10/20/2004 10:51:57 PM EST
Link Posted: 10/21/2004 4:35:26 AM EST

Originally Posted By Tweak:
lippo,

is it a fixed (non fixed collapsible) stock?



It's a fixed A1 stock. I didn't think about that, I'll see if the buffer is is being stopped in the buffer tube for some reason.

Is that what you are pointing too?
Link Posted: 10/21/2004 5:33:04 PM EST

Found out what the problem was.

I took the stock off and checked to see if the bolt carrier would come all the way back. It didn't. So I took out the buffer retainer and buffer retainer spring. It worked. Which meant, the buffer retainer was too long, so it was hitting the bolt carrier by the firing pin head. So I filed it down a bit and it worked. The bolt carrier came all the way back, like it should. This was with the stock removed.

I replaced the stock and it happened again. The bolt carrier wouldn't come back.

The stock screw is too long. It's stopping the buffer from coming all the way back. So tomorrow, I'll cut the stock screw down by half and that should fix the problem.

Link Posted: 10/21/2004 11:07:30 PM EST
Link Posted: 10/23/2004 6:39:33 AM EST
It's a fixed A1 stock.

You have the longer A2 stock screw. Cut off 5/8" from the end of the screw.
Top Top