Warning

 

Close

Confirm Action

Are you sure you wish to do this?

Confirm Cancel
Member Login

Posted: 8/12/2007 8:23:09 PM EDT
I bought a beta mag this weekend at the gun show. When I got it home I tried to load it and could not get more the 60 rounds in it. I took it back and they gave me a new one. I got it loaded but when I got out today and tried to shoot it kept jamming on me. The ammo was gettin stuck in the bottom of the feed clip. Has anyone had trouble like this? Also when I loaded it the bullets cut grooves in the top of the magazine. Is this normal? Any help would be appreciated.
Link Posted: 8/12/2007 8:26:39 PM EDT
[Last Edit: 8/12/2007 8:28:59 PM EDT by BSTOCK]
It's not normal. I have several in 5.56 & 9MM and have never had a problem. let us know how you make out.

Edited to add: Did you use the graphite as instructed? Was the mag new? Did you use any loading device?
Link Posted: 8/12/2007 8:35:32 PM EDT
[Last Edit: 8/12/2007 9:12:18 PM EDT by WAR1911]
height=8
Originally Posted By BSTOCK:
It's not normal. I have several in 5.56 & 9MM and have never had a problem. let us know how you make out.

Edited to add: Did you use the graphite as instructed? Was the mag new? Did you use any loading device?


Yes I used the graphite and the personal loader that came with it. Yes it was new. After I had problems with the first on I followed the instuctions step by step thats when I noticed the ammo was cutting into the top of the magazine. I sent an email to beta and I am waiting on a reply from them.
Link Posted: 8/12/2007 8:42:03 PM EDT

Originally Posted By WAR1911:

Originally Posted By BSTOCK:
It's not normal. I have several in 5.56 & 9MM and have never had a problem. let us know how you make out.

Edited to add: Did you use the graphite as instructed? Was the mag new? Did you use any loading device?


Yes I used the graphite and the personal loader that came with it. Yes it was new. After I had problems with the first on I followed the instuctions step by step thats when I noticed the ammo was cutting into the top og the magazine. I sent an email to beta and I am waiting on a reply from them.


I am sure Beta will take care of you. Good luck & let us know how you make out.
Link Posted: 8/13/2007 7:02:59 AM EDT
[Last Edit: 8/13/2007 7:09:19 AM EDT by CB1]
the top of the feed tower gets pretty worn after you use it. I have used my c-mag about 14 times and the wear stopped after a while. To be safe, I just ordered a spare feed tower in the event that the current one fails.

If I remember, the tower is like $14 and worth it to keep a spare.

I'm about to buy the whole replacement/repair kit from BetaCo to keep in the tool box.

I'll post a pic of my tower in a few minutes...
here is my tower




as for the jamming; I put a nice pile of graphite on the bullet followers and then load. I have not had that problem. maybe BetaCo will help. They never answered my emails, your better off calling them. I got through to them fast when I called them for questions and such.
Link Posted: 8/13/2007 9:58:41 PM EDT
Cb1 that is what my feed tower looks like. I have not heard anything from Beta yet. I loaded the magazine by hand today and did not have any trouble I have not had a chance to shoot it. I am going to order a spare feed tower also. Thanks for the help
Top Top