Warning

 

Close

Confirm Action

Are you sure you wish to do this?

Confirm Cancel
PSA
Member Login

Site Notices
Posted: 5/2/2009 8:35:26 PM EDT
A friend of mine gave me his AR to look at because the bolt was not locking back on an empty mag. it's chambered in 7.62x39.

well i tried to shoot it yesterday and it won't even fire. the primer gets dimpled but other that that...nothin. he gave me new wolf ammo to shoot out of it, and i tried 6 different rounds and got the same result every time.

any body have any ideas as to what would be causing this?
Link Posted: 5/2/2009 8:52:04 PM EDT
Originally Posted By Wils91:
A friend of mine gave me his AR to look at because the bolt was not locking back on an empty mag. it's chambered in 7.62x39.

well i tried to shoot it yesterday and it won't even fire. the primer gets dimpled but other that that...nothin. he gave me new wolf ammo to shoot out of it, and i tried 6 different rounds and got the same result every time.

any body have any ideas as to what would be causing this?


Is the hammer spring weak? Is the gun clean? Have you inspected the FP tip carefully?

Link Posted: 5/2/2009 9:01:56 PM EDT
i checked the firing pin and it looked in good shape. the gun was clean and lubed.

are the firing pins different in the 7.62 type AR  than in the 5.56 AR? maybe he had put the wrong firing pin in?

not positive about the hammer spring.
Link Posted: 5/2/2009 9:07:04 PM EDT
[Last Edit: 5/2/2009 9:08:38 PM EDT by Desert_AIP]
I would remove and reinstall the trigger and hammer to make sure the springs are in the proper orientation.
It's easy to install them upside down.

Look here for help
Build your own Lower Receiver

Next check that the bolt is fully seating and rotating into battery.
Is the chamber and bolt lug area dirty?

The original problem, bolt not locking back is most likely mag related.  Which mags are you using?
Link Posted: 5/2/2009 9:13:01 PM EDT
i'll try reinstalling the trigger group. bolt and lugs are clean.

i know the not locking back is cause of the mags. the ones the guy has been using are 5.56 mags.
Link Posted: 5/3/2009 1:40:22 AM EDT
well i tore out the trigger assembly. there is no large spring on the trigger part, only the hammer. it is a 2 stage trigger like i thought. but only a spring under a piece held in place by a pin. (not sure what that part is called? the disconnector?)

i'm guessing the lack of the bigger spring on the trigger is why the firing pin is not fully striking the primer. can any one back up that assumption?

the thing is though, that the trigger when the hammer is down, still drops the hammer and the trigger itself returns to normal so i'm a little confused by that.

Again, this is not my rifle but a friends, i have no idea what brand of  trigger this is. i'll have to get in touch with him to see if he has the other trigger spring. if that is the case, where could a replacement be gotten from and would the spring from say my AR work in it just to test and see if that is the problem after all?

thanks for the help so far guys
Top Top