Warning

 

Close

Confirm Action

Are you sure you wish to do this?

Confirm Cancel
Member Login

Posted: 4/15/2006 3:28:00 PM EST
I recently bought an upper from CMMG, and went shooting for the first time today. While I was shooting it, I noticed that it was having some feeding problems. After about every shot it would either not load a round, or the bolt carrier would not go forward all the way. At first I thought that it might be a simple break in issue. After it did it consistently for about 60 rounds I decided to take it apart to see if it was catching on anything. Once I got it apart I noticed that the bottom of the gas key on the bolt carrier, where the gas tube feeds into the gas key, was a little deformed. I stopped shooting then because I didn't want to cause any more damage. When I got home I took off the front handguards and noticed that if I pressed down on the gas tube lightly the bolt carrier would function properly. However if no pressure was being put on the gas tube the bolt carrier would stop when the gas key and the gas tube hit. Very minimal damage was done to the gas key, and none that was noticable to the gas tube. I would take a picture of the gas key, but my camera sucks.

I contacted them once I got back from the range, and they said to send it in and they would look at it. Before I did that I was wondering if any of you had any insight on this. I was hoping one of you had a simple fix so I wouldn't have to send it off.
Link Posted: 4/15/2006 3:50:42 PM EST
Top Top