Warning

 

Close

Confirm Action

Are you sure you wish to do this?

Confirm Cancel
Member Login

Posted: 8/9/2014 6:00:10 PM EDT
Shot pretty well
Out of 220 rounds.
Had five light primer hits. Feed them thru again and they went bang.
Had five blow the primer out and jammed the lower trigger reset.
Had to pop off the upper and shake them out.
This was in an almost New SIG 516 so I now it was not due to a worn firing pin or worn lock up.
When I detailed cleaned it back at home. No damage was found from the blown primers in the fire control group. Won’t trade for any more of this stuff. I traded some of my M855 ammo for this stuff to get some non-Metal Core Ammo.
Link Posted: 8/11/2014 5:43:35 AM EDT
Originally Posted By ontmark:
Shot pretty well
Out of 220 rounds.
Had five light primer hits. Feed them thru again and they went bang.
Had five blow the primer out and jammed the lower trigger reset.
Had to pop off the upper and shake them out.
This was in an almost New SIG 516 so I now it was not due to a worn firing pin or worn lock up.
When I detailed cleaned it back at home. No damage was found from the blown primers in the fire control group. Won’t trade for any more of this stuff. I traded some of my M855 ammo for this stuff to get some non-Metal Core Ammo.
View Quote


Hi,

Thanks for the information. Oh by the way did you mean steel core vs. metal core? I shot bunch of this in the 90's and it was all lead core and hot.

Thanks:-)
Link Posted: 8/11/2014 9:07:09 AM EDT
I shot a ton of that ammo in the mid-90's. Never had any problems. Seemed a little hot compared to XM-193.
Link Posted: 8/12/2014 7:16:42 AM EDT
I've shot a few hundred of these, late 80's or very early 90's mfg date. Zero issues, no lost primers or anything like that.

Top Top