Warning

 

Close

Confirm Action

Are you sure you wish to do this?

Confirm Cancel
Member Login

Posted: 7/2/2008 5:46:44 PM EDT
hi i need help from the expert,
my ciener will stop after 3 to 4 rounds of full auto fire i am using a high velocity ammo. when i check the bolt i can see that the hammer is down and there is no sign of the firing pin hitting the live ammo inside the chamber.

what can i do?
Link Posted: 7/2/2008 5:59:32 PM EDT
Do you have the anti-bounce weight installed?
Link Posted: 7/2/2008 6:38:40 PM EDT
Check you firing pin.

It may be broken.
Link Posted: 7/3/2008 3:12:19 AM EDT
Link Posted: 7/3/2008 5:28:56 AM EDT

Originally Posted By badazzar15:
Sounds like you have a bolt bounce issue. you need to run the anti-bounce weight and maybe a stiffer recoil spring, especially if your running high velocity ammo.


I was having a similar problem with my 22 upper. It ran great in semi-auto but in full-auto it wouldn't work most of the time. I had the ball detent mod done and it still didn't fix the problem. I had to install a lakeside recoil spring and the anti-bounce weight. I thought I could use just the ball detent mod and get rid of the anti-bounce weight but I was wrong. Still have to use both to make the upper work properly.

The upper works great now. Badazzar15 helped me with mine and I am sure he and others on here will be able to get yours running like a champ.
Link Posted: 7/3/2008 11:21:58 PM EDT
the 22 conversion was running perfectly, just suddenly it stopped i used the anti bounce it will only shoot about 5 rnds in full auto. i will try to use lakeside springs
thannks

Link Posted: 7/4/2008 2:17:58 AM EDT
Link Posted: 7/21/2008 7:44:27 PM EDT
hey guys thanks for the help the stiffer spring and antibounce did it
Link Posted: 7/22/2008 2:00:48 AM EDT
Top Top