Warning

 

Close

Confirm Action

Are you sure you wish to do this?

Confirm Cancel
Member Login

Posted: 11/4/2009 4:41:37 PM EST
So for some odd reason my 10.5" is not locking open after the last round (one round magazine, tried it about 30 times).

Strange part, is that after shooting supressed, and getting the gun really ditrty on the inside (i.e. 50-100 rounds), the bolt WILL hold open all of a sudden?

I'm guessing I need a heavier buffer perhaps (using standard carbine buffer) and that it's going to fast when it's clean, and slows down as it gets dirty until it holds open...but i'm just guessing. Gas system should be okay...

i get ejection at about 3 o'clock...5-10 feet...had the gas port worked on by adco...assuming everything is fine there.
Link Posted: 11/4/2009 6:31:40 PM EST
Link Posted: 11/5/2009 2:33:16 PM EST
Originally Posted By yarbsea:
So for some odd reason my 10.5" is not locking open after the last round (one round magazine, tried it about 30 times).

Strange part, is that after shooting supressed, and getting the gun really ditrty on the inside (i.e. 50-100 rounds), the bolt WILL hold open all of a sudden?

I'm guessing I need a heavier buffer perhaps (using standard carbine buffer) and that it's going to fast when it's clean, and slows down as it gets dirty until it holds open...but i'm just guessing. Gas system should be okay...

i get ejection at about 3 o'clock...5-10 feet...had the gas port worked on by adco...assuming everything is fine there.


Are you leaking gas ( gas block , gas tube , gas key ) untill the fouling plugs the leak ?

Also , is the gas block 100% over the gas port in the barrel ?

Does it do it with and w/o the suppresser ?

God bless
Wyr
Top Top