Warning

 

Close

Confirm Action

Are you sure you wish to do this?

Confirm Cancel
PSA
Member Login

Posted: 9/20/2009 6:07:07 PM EST
So I found a good deal on a 6.8 SPC Complete upper form RRA and had to have. I am using Barrett mags and remingtion OTM ammo.

For the most part it is just short stroking. It ejects fine after the first round but, you can see where the bolt only came back far enough to eject and then it is stuck. It did this pretty regularly and sometimes it would feed fine? A few other rounds it tried to chamber the next round only to have it stop half way but, the round was never stuck.

I haven't worked on it much and I was in too big of a hurry to go shoot to start with today but, I had to try it out!

I have this on a RRA that I built myself. It was a new build and it is possible I didn't lube something properly although everything feels good on the lower.

I am using a Magpul CTR stock with a standard carbine spring and buffer. Do I need a different buffer for the 6.8?

Other than that I am out of ideas. I believe this upper has the m4 feed ramps as well.

Let me know what you think? Maybe I need to disassemble, clean and go at it again?
Link Posted: 9/20/2009 7:24:46 PM EST
Sounds like you have the right idea. If it is brand new then clean and cycle it some first. I would also try some different ammo. Remington is a little weak. But the buffer and spring should be fine.
Link Posted: 9/20/2009 10:41:37 PM EST
[Last Edit: 9/20/2009 10:43:40 PM EST by AR-Performance]
Link Posted: 9/21/2009 5:56:41 AM EST
I would definitely get some "stronger" ammo to try out. I've not liked any of the Remington ammo out there for the 6.8 SPC.
Top Top