Warning

 

Close

Confirm Action

Are you sure you wish to do this?

Confirm Cancel
Member Login
Site Notices
9/22/2017 12:11:25 AM
Posted: 3/18/2006 3:35:20 PM EDT
[Last Edit: 3/18/2006 6:38:05 PM EDT by ggllggll]
Okay, I'm building for the first time today.

I've got the trunnion, rear trunnion, and trigger guard installed, and riveted.

Just for the hell of it I put a mag in but it wont lock up.

What should I look for? It sits all the way in the mag well but doesn't latch. I'm thinking the mag catch is too long?

Anyway, thanks in advance!

Matt
Link Posted: 3/18/2006 3:59:21 PM EDT
I think your front trunnion is back just a smigion too far. I usually fit the mag before riveting the trunnion in just to make sure. Found out the hard way on my first build.
Link Posted: 3/18/2006 4:16:46 PM EDT
Try all your mags. If they all won't click then you can take some metal off the mag catch. Which receiver did you use?
Link Posted: 3/18/2006 4:24:41 PM EDT
[Last Edit: 3/18/2006 4:26:49 PM EDT by FREEFALLE7]
I had the same problem on my first build.

I fixed it by removing metal from (under the mag catch/triggerguard)the rear of the magwell.

just remove a small bit at a time until she latches.

I have had this happen even after I fitted the mag, all was good and loose untill I rivoted the trunion and then she tightened up.

just file on the rear of the magwell until it fits. If this doesnt work then you could file the mag catch.

I myself would only file the mag catch as a last resort IMO.

Remember if you didnt do this, rivot the triggerguard first, fit the mag then rivot the front trunion.

Do this and you should be fine.

Good luck and post pics when she is done.

FREE
Link Posted: 3/18/2006 4:58:10 PM EDT
DCI receiver.

Free...I'll try that, thanks for the advice.

Probably F'd up my first build anyhow

Lessons learned
Top Top