Warning

 

Close

Confirm Action

Are you sure you wish to do this?

Confirm Cancel
Member Login

Site Notices
Posted: 5/14/2009 6:31:02 AM EST
[Last Edit: 5/14/2009 6:32:14 AM EST by fuzzy03cls]
Hello,

I have a WASR 10/63. Has been fine with the 500 rounds I put through her so far. Fit the Tapco polymer mags fine & steel mags no wobble with either.
I notice when fitting her with a X300 light, & eotech knockoff, the mag release pin was half way out. I took a punch & started to tap the pin back through only to tap & have it shoot out the other end & the entire mag release spring & parts went ping. After I found everything, I spent an hour trying to figure out how to put it back on.

So how do it do it? I guess I need a new pin since it's so loose, I can order that.

Thanks
Link Posted: 5/18/2009 3:23:45 AM EST
Bump

Any input would be helpful.

Thanks
Link Posted: 5/25/2009 8:45:24 PM EST
[Last Edit: 5/25/2009 8:48:40 PM EST by Dystopia]
I replied in the wrong thread sorry.
Link Posted: 5/26/2009 6:18:19 AM EST
You might have better luck in the Build It Yourself forum.
Link Posted: 6/2/2009 5:56:57 AM EST
TAG
Same thing happen to my WASR as well, so back to the top with this one!
Link Posted: 6/2/2009 6:21:16 AM EST
The mag catch is riveted in place. If you REALLY want to fix it yourself then you will have to buy a new rivet from K-var.com. Install the mag catch and use 1/4" ball bearings to flare the ends of the tube on the rivet.

How old is it? I would call Century and see if the monkeys there can fix it.
Link Posted: 6/9/2009 6:23:27 PM EST
that spring is a PITA! Ball bearing trick would be the way to peen the ends of the pin after install. IM me if you want a go-by pic
Link Posted: 6/17/2009 8:48:42 AM EST
Same thing happened on my CIA M70AB2, its heading back to century at the end of the week for this and another problem. Hopefully it doesnt come back worse then it is now.
Top Top