Warning

 

Close

Confirm Action

Are you sure you wish to do this?

Confirm Cancel
PSA
Member Login

Posted: 11/19/2008 10:13:50 AM EDT
What gives?  It feeds properly every time except when I emty the mag and put a fresh one in.  About half of the time the bullet never leaves the magazine and I just get a click.
Link Posted: 11/19/2008 10:18:47 AM EDT
Don't ride the carrier foreward.
Pull it all the way to the rear and let it slam home.
Link Posted: 11/19/2008 10:36:24 AM EDT
Are you sure you have the magazine locked in properly?
Link Posted: 11/19/2008 11:00:25 AM EDT
Originally Posted By LUGERMAN:
Are you sure you have the magazine locked in properly?


Yeah or a Bad mag.
Link Posted: 11/19/2008 12:25:00 PM EDT
Originally Posted By shootdaily:
Don't ride the carrier foreward.
Pull it all the way to the rear and let it slam home.


+1 this is it.  
Anything else and it wouldn't just happen on the first round out of a mag.
Link Posted: 11/19/2008 12:31:52 PM EDT
[Last Edit: 11/19/2008 12:32:50 PM EDT by Chris_1522]
Link Posted: 11/19/2008 1:00:47 PM EDT
load 1 less?
Link Posted: 11/19/2008 1:10:21 PM EDT
Originally Posted By shootdaily:
Don't ride the carrier foreward.
Pull it all the way to the rear and let it slam home.


This, AK's arent supposed to be babied! I have had the same issue with one of my AK's once I stoped riding it forward, I didnt have a problem anymore.

Link Posted: 11/19/2008 2:22:30 PM EDT
Your problem is that AKs do not have a "charging handle". They have an operating handle.
In other words, stop thinking of it (and treating it) like an AR.
Top Top