Warning

 

Close

Confirm Action

Are you sure you wish to do this?

Confirm Cancel
Member Login

Site Notices
11/9/2018 9:21:38 PM
Posted: 10/30/2018 9:01:17 PM EST
While testing out a brand new X95 today I experienced an issue with the charging handle being stuck and the rifle unable to be manually cycled with a live round in the chamber. The rifle will eject fine when fired though.

I’ve done some searching and it seems others have had this issue but no cause has been pinpointed for sure. My initial thoughts, and what others seem to have found to be the problem, is that the cosmoline/packing grease is causing the bolt to stick.

Has anyone else experienced this? Any other ideas as to the cause? I plan to thoroughly clean the chamber with a solvent before shooting again.
Link Posted: 10/30/2018 10:24:02 PM EST
I had mine lock up at the range just as the range was closing. Had to fire the round and it ejected fine. No clue what the lock up was due to.
Link Posted: 11/2/2018 5:16:10 AM EST
That stuff was everywhere on my new x95. Trigger pack, inside the bolt, bolt carrier, inside the metal frame, frame rails, under the scope rail, barrel exterior under the rail and handguard, mag release button and linkages. I used electronic contact cleaner and tons of soaked swab pads. Just flushing it didn’t remove it, had to actually scrub it off.
Link Posted: 11/2/2018 10:37:57 PM EST
You've stripped and cleaned the BCG?

AJ
Link Posted: 11/4/2018 9:30:33 PM EST
The BCG was stripped and cleaned yes. Have now put 300 additional rounds through the rifle with no further issues.
Top Top