Warning

 

Close

Confirm Action

Are you sure you wish to do this?

Confirm Cancel
Member Login

Site Notices
Posted: 8/7/2018 10:30:51 PM EDT
So I’m out on my weekly pig patrol last Saturday night and notice that my unit had come slightly loose. Of course it’s in the middle of the night and all I really have with me is a flashlight and no tools except way back in the truck. Anyways I’ve got a buddy with me and figure he can shoot first and I’ll see what happens if I can follow up. Long story short no pigs.

So Sunday I get out my tools and take it off and it appears that the unit has come slightly loose from the male part that screws into the female part of the base. I take my wrench and tighten it up real good I think and try and eyeball it to make sure it’s square and set it aside.

Today I called Flir and got the update and decide to put it back on. Once I remounted it, it still had the lateral wobble. I tightened it up again but now it’s to the point that I’m afraid that the screw might break or strip. Even this tight it can still move a little with some force.

The problem seems to stem from the fact that the male part of the base only screws into the unit in one place. Maybe I’m wrong on this or missing something. Has anybody else seen or experienced this? Also it doesn’t seem to have a groove or anything that self aligns so how am I supposed to keep it straight?

Thanks in advance.
Link Posted: 8/8/2018 8:40:16 AM EDT
Are you sure that the ADM rail clamps aren't a touch loose?
Link Posted: 8/8/2018 1:33:48 PM EDT
Yes. At first I thought exactly the same thing but when I took it off the gun it was pretty evident where it was loose. If you have one and are able to look at the mounting system there is a female part that has the qd levers and rail grabber part which is connected to a male part by two screws. The male part is only connected to the unit though by one screw that I could find. And this is where it came loose. Even when I cranked that one down tight it still has a little play.
Top Top